1

When I start the User Profile Synchronisation Service on the Server, I get following error in the ULS Logs :

UserProfileApplication.SynchronizeMIIS: Failed to configure ILM, will attempt during next rerun. Exception: System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)
at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at Microsoft.IdentityManagement.SetupUtils.IlmWSSetup.ExecuteSQL(String queryString)
at Microsoft.IdentityManagement.SetupUtils.IlmWSSetup.IlmBuildDatabase()
at Microsoft.Office.Server.UserProfiles.Synchronization.ILMPostSetupConfiguration.ConfigureIlmWebService(Boolean existingDatabase)
at Microsoft.Office.Server.Administration.UserProfileApplication.SetupSynchronizationService(ProfileSynchronizationServiceInstance profileSyncInstance).

And In Event Log the error shows as this:

ILM Database could not be created: Error sent to Windows Event Log running : EXEC dbo.ObjectSchemaPopulateFromConfig: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

The connection to Database server is fine and The User Profile service is created following all the proper guidelines. Please help

  • Starting service is an issue related to permission of account under which service is running. Go to SQL server management and give right to service account to other database as db_owner. This issue always come with me bcoz of permission issue. Then restart timer service. – ateet Oct 20 '14 at 6:11
0
  1. please check your environment based on the official hardware and software requirements:

http://technet.microsoft.com/en-us/library/cc262485.aspx

  1. Starting User Profile Synchronization Service will need a little long time. If starting User Profile Synchronization Service failed, please check your service account's permission.

  2. Be sure that Service Pack1 and cumulative updates are installed. Mare sure that once you've updated hotfix for SharePoint 2010, you must use the command "psconfig -cmd upgrade -inplace b2b -wait" and then check product and patch installation status (Central Administration >Upgrade and Migration > Check product and patch installation status)

  3. A member of Farm Administrator group
  4. A member of Local Administrator group in the server you are running SharePoint 2010 as application server
  5. Replicate Directory Changes permission on a domain
  6. Log on locally policy in the server you are running SharePoint 2010 as application server (Start> Administrative Tools > Local Security Policy >Local Policies > User Right Assignment. R-clickAllow log on locally and select Properties. You will then do a few easily steps to complete configuration).
  7. The application pool accounts for Web applications are assigned to the db_owner role for the content databases.
  8. This account is assigned to the WSS_CONTENT_APPLICATION_POOLS role associated with the farm configuration database.
  9. This account is assigned to the WSS_CONTENT_APPLICATION_POOLS role associated with the SharePoint_Admin content database

If the "Starting" keeps forever, you can use the following command to stop User Profile Service Application. Get-SPServiceInstance Stop-SPServiceInstance -Identity “service application GUID”

Or you can also delete the existing User Profile service application and then re-provision one.

The relevant article: http://www.harbar.net/articles/sp2010ups2.aspx

https://social.technet.microsoft.com/Forums/sharepoint/en-US/4359a76f-2447-41b1-be38-fbff462e6da8/failure-configuring-ilm-for-user-profile-service-application

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.