2

I have tried many tutorials but I am still not able to figure out how to create Sharepoint surveys for which anonymous people can respond to.

Anonymous users can see the survey web part and the response button. But when an anonymous user clicks the button, it asks for a login within a popup. If the user clicks cancel, the page becomes blank with "401 UNAUTHORIZED" message.

I have enabled anonymous access for the web application, site collection and site. I have done the step of setting unique permissions on the survey list and letting anonymous users read and edit and add all responses.

I am still now able to solve it. Thanks in advance for any help. Even pointers to articles or books are appreciated.

  • There should be some reference in your Survey list/Page/Navigation to protected areas of the site. It can be an image in a picture library or page which has no permissions to anonymous user. If the mentioned site is intranet, then it won't be truly anonymous unless you create separate web application and enable the access. More on this link – Amal Hashim Oct 19 '14 at 11:05
  • Is publishing feature enabled? – Christoffer Oct 19 '14 at 11:25
1

From your question I read that you have configured Anonymous Access, right from your Web Application to SharePoint Survey List but users are facing issues when they click on Respond to Survey button.

Now check if Limited-access user permission lockdown mode feature is Active at Site Collection Feature

Go to Site Settings > Site Collection Administration > Site Collection Features > Limited-access user permission lockdown mode

If this feature is Active, please Deactivate it.

enter image description here

Now what happens if Limited-access user permission lockdown mode feature is Active?

When this feature is set to Active, permissions for users with “limited access” permissions, such as Anonymous Users, are reduced, preventing access to Application pages including item properties or list views. Additionally, if a document, folder, or library has unique permissions, those users will not be able to:

  • Use the drag and drop feature to upload documents

  • Browse to the affected folder

  • Use the Shared with feature

  • Open documents in the Office client

  • Some callout features on documents and folders will not render as expected

1

If you're having a SharePoint 2010 webapplication which allows access to anonymous users, you may find that when users click on listitems, they get prompted to log in. This is the case for publishing sites where the ViewFormPagesLockdown feature is automatically activated and denies access to the list and its items. So for example when you're having a list with news items and you want users to be able to click on the item so they can read it, they will have to log on before they can see it.

Warning: Keep in mind that when you will disable the ViewFormPagesLockdown feature, it will have consequences. One of them being that the /_layouts/viewlsts.aspx page showing all lists in the site will become available for anonymous users as well. This means that all your lists will be accessible by default unless you specifically define permission inherritance to be broken on each list and specify anonymous users to not have access. Some lists may not be blocked this way, for example your pages library. This means that anonymous users will be able to see allpages that exist in the library. So consider building a custom webpart to disclose information from lists to anonymous users above disabling this feature.

In order to prevent this from happening, follow these steps:

  • On one of your SharePoint servers, open up the SharePoint 2010 Management Shell Type:

    Get-SPFeature -site http://<yoursiteurl>

  • Identity ViewFormPagesLockdown If you're seeing an error as shown on the following screenshot, the ViewFormPagesLockdown feature is not activated on your site and the problem is not caused by this.

  • If the ViewFormPagesLockdown feature is enabled, go to the site for which you want to allow anonymous access to lists and listitems and go into Site Actions -> Site Permissions
  • In the ribbon click the Anonymous Access button and set the radio button to Nothing. Click OK to save the setting.
  • Next, execute the following command to disable the ViewFormPagesLockdown feature in the management shell on your SharePoint server:

    Disable-SPFeature -Identity ViewFormPagesLockdown -Url http://<yoursiteurl>

  • Now either run IISRESET if you don't mind putting your whole SharePoint 2010 farm offline for a few seconds or just recycle the application pool in IIS to flush cached contents. Also close all your browser instances.

  • Open up a new broswer and go back into your site. Again, go via Site Actions -> Site Permissions and click the Anonymous Access button in the ribbon

  • Turn anonymous access back on by clicking on the Entire Web site radio button followed by a click on OK. Make sure your list inherits from its parent site which allows anonymous users.

  • Log off and close your browser

  • Go back to your site with a new browser without logging in and verify if you can now access a list item anonymously

All the step above taken from this post.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.