1

Yesterday I switched from VS12 to VS2013 Ultimate, opened my app in VS2013 and deployed it. Worked as expected. However I have one Workflow Issue, when I go to the XAML and drag an item from the toolbox to the flow (no matter which item), I get an red error bar, saying "Could not generate view for CopyItem". It also gives me an error message:

enter image description here

Then when I close en reopen the project and workflow designer, the view is generated but when I click on it the following error message appears:

enter image description here

How can I solve this?

Edit: it appears to have something to do with this particular project. When I create a new project and add a workflow I have no issues...

1

I've done some extensive research on this issue and I finally have a working solution. I've done the same as @tomvanderhoek, i.e. installed VS 2013 side by side with VS 2012. This is a bad idea if you're developing workflows.

For a reason specified on another thread (Retract solution (WSP) in Visual Studio 2013 - Delete Content Types) I cannot use VS 2013. So I rolled back to VS 2012 and tried to continue developing workflows again. This is the moment where I started to face the issue.

Things I've tried to fix VS 2012 Workflow designer problems (order is important):

  1. Uninstall VS 2013. Didn't help.
  2. Repair VS 2012. Didn't help.
  3. Repair Office developer tools for VS 2012. Didn't help.
  4. Uninstall VS 2012, uninstall Office developer tools for VS 2012, install VS 2012, install Office developer tools for VS 2012. Finally I've got things fixed and I can continue developing workflows again.

To summarize, if you're developing workflows (Workflow Manager) and content types in the same project do not use VS 2013! This might get you in unwanted trouble.

The company I'm currently working for isn't MS gold partner and has to pay some serious money for my VS 2013 Premium license and it's sad to see that the product isn't working properly. I hope MS resolves this issue soon.

|improve this answer|||||
0

Solved, was a compatability issue between vs2012 and vs2013.

|improve this answer|||||
  • Please, write, what exactly have you done to fix the problem? – Ruslan Dayanov Oct 20 '14 at 12:34
  • I am facing the similar problem. Could you please describe the steps you made to solve this issue? – Slaven Semper Nov 17 '14 at 9:57
0
+50

My project was not very large so I recreated it in VS13. After that I everything worked fine

|improve this answer|||||
0

I had the same problem with Visual Studio 2015 Commmunity. It was probably caused by the fact that I installed Visual Studio 2017 on the same machine and some dll references got messed up. The fix was to remove and re-add the references to

  • Microsoft.SharePoint.DesignTime.Activities and
  • Microsoft.SharePoint.DesignTime.Activities.Design.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.