6

I have SharePoint 2013 server , but when i run the product configuration wizard, it raised the following error "Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown":-

enter image description here

and here is the related logs:-

 Starting Service SPDistributedCacheServiceInstance
10/16/2014 11:55:32  5  INF                  Detected that this is a build to build upgrade. Re-provision the SPDistributedCacheServiceInstance service
10/16/2014 11:55:43  5  INF                Leaving function UpgradeTask.StartAllServices
10/16/2014 11:55:43  5  INF                SyncUpgradeTimerJob: sleeping for 10 seconds
10/16/2014 11:55:53  5  INF                SyncUpgradeTimerJob: SPTIMERV4 is not running anymore. Return -1.
10/16/2014 11:55:53  5  ERR                The exclusive inplace upgrader timer job failed.
10/16/2014 11:55:53  5  INF                Entering function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                  Resource id to be retrieved is UpgradeTaskFailConfigSyncDisplayLabel for language English (United States)
10/16/2014 11:55:53  5  INF                  Resource retrieved id UpgradeTaskFailConfigSyncDisplayLabel is Failed to upgrade SharePoint Products.
10/16/2014 11:55:53  5  INF                Leaving function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                Entering function Common.BuildExceptionMessage
10/16/2014 11:55:53  5  INF                  Entering function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                    Resource id to be retrieved is ExceptionInfo for language English (United States)
10/16/2014 11:55:53  5  INF                    Resource retrieved id ExceptionInfo is An exception of type {0} was thrown.  Additional exception information: {1}
10/16/2014 11:55:53  5  INF                  Leaving function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                Leaving function Common.BuildExceptionMessage
10/16/2014 11:55:53  5  ERR                Task upgrade has failed with a PostSetupConfigurationTaskException An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: Failed to upgrade SharePoint Products.
10/16/2014 11:55:53  5  INF                Entering function Common.BuildExceptionInformation
10/16/2014 11:55:53  5  INF                  Entering function Common.BuildExceptionMessage
10/16/2014 11:55:53  5  INF                    Entering function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                      Resource id to be retrieved is ExceptionInfo for language English (United States)
10/16/2014 11:55:53  5  INF                      Resource retrieved id ExceptionInfo is An exception of type {0} was thrown.  Additional exception information: {1}
10/16/2014 11:55:53  5  INF                    Leaving function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                  Leaving function Common.BuildExceptionMessage
10/16/2014 11:55:53  5  INF                Leaving function Common.BuildExceptionInformation
10/16/2014 11:55:53  5  ERR                An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: Failed to upgrade SharePoint Products.
Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException: Exception of type 'Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException' was thrown.
   at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()
10/16/2014 11:55:53  5  INF                Entering function Common.BuildExceptionInformation
10/16/2014 11:55:53  5  INF                  Entering function Common.BuildExceptionMessage
10/16/2014 11:55:53  5  INF                    Entering function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                      Resource id to be retrieved is ExceptionInfo for language English (United States)
10/16/2014 11:55:53  5  INF                      Resource retrieved id ExceptionInfo is An exception of type {0} was thrown.  Additional exception information: {1}
10/16/2014 11:55:53  5  INF                    Leaving function StringResourceManager.GetResourceString
10/16/2014 11:55:53  5  INF                  Leaving function Common.BuildExceptionMessage
10/16/2014 11:55:53  5  INF                Leaving function Common.BuildExceptionInformation
10/16/2014 11:55:53  5  INF                Entering function get CommandCollection.this[string key]
10/16/2014 11:55:53  5  INF                  Entering function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                    Found value in collection for key global
10/16/2014 11:55:53  5  INF                  Leaving function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                  Found command global in collection
10/16/2014 11:55:53  5  INF                Leaving function get CommandCollection.this[string key]
10/16/2014 11:55:53  5  INF                Entering function get CommandCollection.this[string key]
10/16/2014 11:55:53  5  INF                  Entering function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                    Found value in collection for key initialize
10/16/2014 11:55:53  5  INF                  Leaving function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                  Found command initialize in collection
10/16/2014 11:55:53  5  INF                Leaving function get CommandCollection.this[string key]
10/16/2014 11:55:53  5  INF                Entering function Command.this[string key]
10/16/2014 11:55:53  5  INF                  Entering function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                    Found value in collection for key SINGLESERVER
10/16/2014 11:55:53  5  INF                  Leaving function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                  Found parameter SINGLESERVER in collection
10/16/2014 11:55:53  5  INF                Leaving function Command.this[string key]
10/16/2014 11:55:53  5  INF                Entering function Command.this[string key]
10/16/2014 11:55:53  5  INF                  Entering function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                    Found value in collection for key upgradesessionid
10/16/2014 11:55:53  5  INF                  Leaving function CommandCollectionBase.Get
10/16/2014 11:55:53  5  INF                  Found parameter upgradesessionid in collection
10/16/2014 11:55:53  5  INF                Leaving function Command.this[string key]

is the problem related to Distributed cache server or what exactly ? can anyone advice please?

5

take a look at https://social.technet.microsoft.com/Forums/en-US/94a8bb64-e0ea-493f-8e29-01347b1fc6c7/psconfig-fails-failed-to-upgrade-sharepoint-products

You will find a workaround there:

"I run once again the command „PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures“ in the “Bin” Folder as an administrator console session. In the moment I saw the staus “Configurationtask 5 of 6 is executed” I start to run the command “net start SPTraceV4 & net start SPWriterV4 & net start SPAdminV4 & net start SPSearch4 & net start SPTimerV4” in a parallel administrator console session and after that the configuration task finished successfully."

Looks like that may help you.

Another possible solution:

http://sp-vinod.blogspot.de/2013/03/sharepoint-2010-october-2012-cumulative.html

  • so seems in the link you provide there is not a clear solution for the problem,, can u advice which approach i should follow ? thanks – john Gu Oct 16 '14 at 15:37
  • It was just a coincidence that I just searched google and found these two issues. As your log looks like there is no SPTIMERV4 running, I was just assuming that it might be a good idea to start that one and I just linked these two issues :) – user20451 Oct 16 '14 at 15:41
  • no but the sharepoint timer service is running while i run the configuration wizard.. – john Gu Oct 16 '14 at 15:43
  • Sorry, was just a try. As I got similar problems here, I hope somebody find a solution. – user20451 Oct 16 '14 at 15:45
  • Found another one: sp-vinod.blogspot.de/2013/03/… – user20451 Oct 16 '14 at 16:00
0

consider if you are using SQl server Always ON and CliConfg aliases

in my case removing sql server from Always On and directly connecting to server resolved the problem.

please note that it was previously connected through Listener name configured with cliconfg in each server in the farm

specially wss_logging database must be in simple mode and directly connected and not in always on and gave me trouble before a few times before

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.