0

I have a workflow that I need to start when an item is changed but not when an item is created, as I have a separate workflow for that, so the "Start workflow automatically when an item is created" is not selected.

However, the workflow still starts automatically when an item is created and I don't know why.

  • Did you had the workflow to trigger on both created and modified from scratch and then made an additional workflow? Or did u just check "Start when an item is modified"? If there are any changes to the workflow, it must be saved and republished, unchecking and saving is not enough. – Christoffer Oct 15 '14 at 15:49
  • I may have run the workflow once or twice with "Start when created" ticked, but that was a few days ago and I've made many changes and republished since then. – James Fraser Oct 15 '14 at 15:54
  • Did you remove the old workflow from the list? Sharepoint set the old workflow automatically to no new instances when the same workflows is saved and republished but you never know! Might be worth to check out. – Christoffer Oct 15 '14 at 16:18
  • Have you ensured that there is no timer job or some other custom code, from where your workflow is triggered explicitly ? I am not sure how you will do that. But it is also a possibility for triggering a workflow. – Amit Tyagi Oct 15 '14 at 17:12
  • @user19952 I have removed all previous instances of the workflow just to be safe but still no change. – James Fraser Oct 16 '14 at 8:50
1

If we are talking about documents, it could be firing appropriately if you have required fields or multiple content types in your library and you are uploading files. After the upload, you are taken to a page where you can edit the properties and metadata of the file. This is actually an item edit process and could be triggering your workflow.

  • After a document uploads the page just refreshes to show the new document in the library, it doesn't take me to another page. – James Fraser Oct 16 '14 at 8:46
0

You need to go to your web site cache located in

C:\Users{your user name}\AppData\Local\Microsoft\WebsiteCache

Delete this data and republish your workflow. The issue is that SharePoint Designer at times after a lot of modifications to the same workflow causes the workflow to publish an older version.

  • Thanks for the suggestion. I deleted the WebsiteCache file and republished the workflow with no effect. – James Fraser Oct 16 '14 at 8:45
  • Check the ULS log and see if you see the workflow start or any errors. – Joseph D Surgeon Oct 16 '14 at 13:16
  • @JosephDSurgeon Does this need to be done on the SharePoint server or will deleting the cache on my local machine also work? Thank you – Bassie May 10 '16 at 13:24
  • You only need to do it on your local machine cache @Bassie – Joseph D Surgeon May 16 '16 at 9:47
  • @Bassie you only need to do it on your local cache – Joseph D Surgeon May 16 '16 at 9:48
0

Did you also check the Item specific settings? You can add a workflow to a specific List content type, which as well has an option to trigger a workflow automatically. It can be found via

Settings -> Content Types -> Item -> Workflow settings

-1

Making changes in the SharePoint designer usually does not update the workflow start options. Go to the site or the list workflow settings and Edit the workflow start options there. It should update the startup options then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.