I want to remove "Title" column created by default in SharePoint 2013 List. I googled many times.But I got only solutions for SharePoint 2010 version only.Those Solution is not working for this latest version. Anybody please help. Thanks in advance.

5 Answers 5


Well you can hide it to appear on forms, go to List Settings -> Advanced Settings -> Allow management of content types -> check the box

Now come back to List Settings -> Under Content Types -> Click Item content type -> Under columns -> click Title -> Hidden (check the box)

Now it won't appear on the forms, you can similarly remove it from Views.

  • 1
    Arsalan Is there any other option available instead of you suggested answer. because when column is hidden it does not crawled. Jul 20, 2016 at 10:39
  • other option will be to use InfoPath forms or custom forms instead of OOB list forms. Jul 20, 2016 at 13:52
  • 1
    WONDERFUL- it worked!! this solution really helped and I can see the status reflecting in the SP 2013.
    – Sonia
    Mar 6, 2017 at 4:31
  • If there are any detrimental effects caused by implementing this solution, can someone add them to the answer? It's great to be able to hide the Title field from the form (whilst still displaying it in a View because it is the only column that can link to an item), but I vaguely remember reading a blog post about this approach that said there were some drawbacks (i've looked for it but can't find it). Thanks. Apr 23, 2020 at 5:57
  • 1
    There are no drawbacks of it as far as I know, have been using this approach for quite some time and never faced any issue. Apr 25, 2020 at 13:19

As much as I know in SharePoint 2010 you cannot delete "Title" column. You can only rename it and hide it from views and forms

  • Yeah, you can hide it but then you won't have an active field in the all items view to choose the record for edition....
    – user43141
    Jun 10, 2015 at 6:54

Old post I know, but new approach to an old problem.

Don't delete it!

Let me explain... Simply change its contents and name to something you want to keep.

This mass updates existing values (for example where you have imported using Excel), but can also be used for changing the content in a Title column, so you can rename it, then delete the column where the content originally came from.

This worked a treat for me. I had a single line of text

  1. Create a new blank Access database
    1. Click on the "External Data" tab
  2. Click on "New Data Source"
  3. Choose "From Online Services -> SharePoint list"
  4. Select your SharePoint site
  5. Select your SharePoint list

The list, and lookup tables if you use them will get added

Now select "Create" tab and "Query Wizard -> Simple Query"

For your Query add just the column you want to be updated "TitleColumnName" above

Click "Update!" button in query designer then in the "Update To" row that appears in your "TitleColumnName" column you added type [ColumnNameForValueYouWantToKeep], now switch to "View -> SQL View" to check, you should have:

UPDATE YourListName SET YourListName.[TitleColumnName] = [ColumnNameForValueYouWantToKeep];

Run the query, it might take a while...

Now you can check your changes, when you are happy your "Title" column now contains the values from a column you want to keep, you can delete the column which had the values you wanted and use the title column, which now contains those values instead.

Finish off by renaming the title column to the now deleted column name. It will always be "Title" when you check its properties, or access it using scripts, but it will display with the name you give it.

No hiding, no redundant columns, fully usable in SharePoint, CSOM, JS or InfoPath. And bonus is now you get an edit item option from your replaced content title column!


I solved this problem by making sure that the title is not a mandatory field.optional and trying to hide them will not work..you really need to go the site settings and change it to optional.


Simple solution for me was to change the way it was being presented...

List > Modify view > Style > Default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.