1

I've upgraded to the new SP1 and July update for Office Web Apps and it's working fine with Excel and Visio, however I notice Word Documents are no longer working.

When I run Get-SPWOPIBInding everything looks the same:

Application     : Excel
Extension       : XLSX
ProgId          : 
Action          : view
IsDefaultAction : True
ServerName      : server.example.com
WopiZone        : internal-https

Application     : Word
Extension       : DOCX
ProgId          : 
Action          : view
IsDefaultAction : True
ServerName      : server.example.com
WopiZone        : internal-https

Interestingly I've only configured OWA to use HTTP (I've run Set-SPWOPIZone -zone "internal-http" via here) to do that, but the above WopiZone still says "internal-https".

Anyway, any advice on why Word might not be loading in the browser and defaulting to downloading? I am over the VPN at this stage, so I'll try again at work from inside the network.

UPDATE:

I got the following error when searching for Word Documents and trying to preview them:

Exiting GetWOPITargetInternal Early - GenerateWacUrl failed to produce a URL/actionEntry for file XXX with extension 'DOCX'
1

My suspicions were correct: the mismatch between Get-SPWOPIZone and the WopiZone of the Get-SPWopiBinding seemed to cause the error - everything needed to be internal-http.

I followed the article here to remove and then recreate the bindings and Word started working (funny that Excel and Visio worked before but Word didn't!):

Resolution: Remove the link between the Sp farm and WCA 
PS> Remove-SPWOPIBinding –All:$true
Connect SP to the WOPI farm 
PS> $internalName = "wca.demo.dev"
PS> $internalZone = "internal-https"
PS> New-SPWOPIBinding -ServerName $internalName –AllowHTTP 
PS> Set-SPWopiZone -zone $internalZone
  • Just for your attention: Microsoft only recommending running HTTP in test/development and HTTPS for Office Web Apps in production. – Christoffer Oct 15 '14 at 13:32
  • Yes and if you were using a ExternalURL you'd want SSL, however we're only using an internal url at this stage. So no need to manage certificates or take an unncessary performance hit. – PeterX Oct 15 '14 at 23:27
0

are you sure that you viewed Viso-Files through Office Web Apps Server? There is no such functionality. I guess it must have been Visio-Services within SharePoint Server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.