0

On our SharePoint 2013 farm (on-premise), we do not have "department" value on the AD. Hence we add a custom user profile property "XDepartment" and then update the user profiles' using PowerShell. When browse the users on their personal site (My Site) or checking in Central Admin -> Manage User Profiles can see the updated value.

When checking the site collections. By browse to the site collections /_layouts/15/people.aspx or Site Settings -> People and groups. The department column is blank. I believe it is bind to the Out-of-box "Department" property.

Anyway I can change this view to bind with "XDepartment"?

2
  • Mark, can you complete this post so we can answer your question? Commented Oct 15, 2014 at 18:10
  • Matthew, I have updated the questions with my latest finding. Thank you.
    – Mark L
    Commented Oct 17, 2014 at 3:03

1 Answer 1

1

You need to mark the User Profile Property as Replicable. You also have to set the Default Privacy Setting of the property to Everyone and not allow the user to override the setting.

I do have to say though, why not just use the out of the box Department property? Just remove the default AD import mapping and everything else will work as you would like with your PowerShell update. (Or use PowerShell to update the property in AD and let the sync run.) Then you won't have any of these issues?

2
  • We have special requirement to let user manage XDepartment values in termstore and allowed to be used in search result refinement.
    – Mark L
    Commented Oct 20, 2014 at 6:35
  • There are two Department fields OOB. You can satisfy that requirement with the OOB Department field SPS-Department (rather than Department). Commented Oct 20, 2014 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.