1

We started to get this really weird error on our public site environment. Site works fine for public but as soon as user with Admin right provides login credentials for the site to access 'Site Actions' ribbon then this error is displayed. Also, it only happens for some pages as soon as user login but for some pages as soon as admin tries to edit page, error is displayed and after doing 'Discard check out' user can see the page but can't do any changes to the content. I've searched around and found few solutions which I tried but nothing helped.

  1. We have plenty space on DB server
  2. AAMs are correct

Any ideas would be greatly appreciated.

4
  • is it Publishing site? if yes, did you deatciatvate publising feature and reactivate it? – Waqas Sarwar MVP Oct 13 '14 at 18:38
  • if yes, did you deactivate publishing feature and reactivate it? start from site features then site collection features....then activate again from site collection followed by site features. – Waqas Sarwar MVP Oct 13 '14 at 18:43
  • Yes it is a publishing site and I applied the same solution that you suggested and got it yo work before I saw the response. Thank you! – Vera Ryss Oct 13 '14 at 19:40
  • I added my comment as answer, for benefit of community as well as help me get some point. – Waqas Sarwar MVP Oct 13 '14 at 21:58
2

If this is publishing site?did you deactivate publishing feature and reactivate it?

start from site features then site collection features....then activate again from site collection followed by site features.

1

deactivating and activating back SharePoint Publishing infrastructure feature on the site collection level solved the issue. Thank you to Waqas Sarwar MCSE who also, had the solution right.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.