2

I've followed this tutorial to try to sync user's picture from AD to SP 2013 but I've got issue in the first step: In dropdownlist for attribute I can't find 'thumbnailPhoto' to selected. It was disable. https://sharepoint.stackexchange.com/questions/46569/how-do-i-import-active-directory-photos-and-sync-them-with-my-site-collections#=

And there is some picture of my configuration enter image description here

and enter image description here

here is the problementer image description here

After create connection, When I click Start Profile Synchronize, nothing happen. The status still idle. I'v sure that in my AD there are over hundreds UserProfile. The number 17 mean, there are 17 User have accessed to My Site. I don't know why? . Could it be the cause of my problem?

enter image description here

There is one thing that I'm wonder. I can't start Profile Synchronization Service running because of I'm using "Sharepoint Active Directory Import". enter image description here

  • 1
    Do you use Active Directory sync, or FIM? You may need to enter the name yourself – Robert Lindgren Oct 13 '14 at 5:37
  • Yes, I do use Active Directory sync. But dropdown list for attribute still disable. I've updated some picture of my configuration. You can have a look – user3622351 Oct 13 '14 at 6:07
  • You need to fill in it manually in the text box called Attribute. And the click Add – Robert Lindgren Oct 13 '14 at 7:06
  • I've tried it, but still not working. There is something I just found out. After create connection, when I start full sync. Nothing happen. THe status of sync process is still idle, it not change. Could it be the cause of my problem? – user3622351 Oct 13 '14 at 7:13
1

Active Directory Import is new synchronization method introduced in SharePoint 2013. It is highly efficient if only import is required even with AD only.

And that's true, you will not be able to start User Profile Synchronization Service after configuration synchronization method as Active Directory Import

You have to perform some step to create connection with a account that have Replicate Directory Change Permission on a Domain

1.On the domain controller, click Start, click Administrative Tools, and then click Active Directory Users and Computers.

2.In Active Directory Users and Computers, right-click the domain, and then click Delegate Control.

3.On the first page of the Delegation of Control Wizard, click Next.

4.On the Users or Groups page, click Add.

5.Type the name of the synchronization account, and then click OK.

6.Click Next.

7.On the Tasks to Delegate page, select Create a custom task to delegate, and then click Next.

8.On the Active Directory Object Type page, select This folder, existing objects in this folder, and creation of new objects in this folder, and then click Next.

9.On the Permissions page, in the Permissions box, select Replicating Directory Changes (select Replicate Directory Changes on Windows Server 2003), and then click Next.

10.Click Finish.

After performing this operation, you have to create a connection To Active Directory Import which you already did, so edit that file and select the container and click Ok there.

Then you have to map your AD property to User Profile Property. Do remember you to write an Attribute instead of selecting it from dropdown. As dropdown will be disabled for Active Directory Import synchronization method.

In my case, I map mail to Work Email in user profile as shown in below screenshot. enter image description here

If mapping already exist but attribute is null there then remove that mapping by clicking Remove button. Then add an attribute there and click ADD. Finally click ok.

Note: Don't forget to click add button after adding an attribute there.

Then run the full synchronization, check whatever property you had mapped are successfully imported to User profile.

But still, User Profile Synchronization service is not running. It all work without synchronization service running in case of Active Directory Import synchronization method. And even you will not b e start to start it. That's I don't know the exact reason behind it!

But finally all things work perfectly after doing steps that I mentioned above.

FYI:- http://blogs.technet.com/b/meacoex/archive/2013/08/04/step-by-step-active-directory-import-for-sharepoint-2013.aspx

  • tks you so much. Now synchronizatino work OK. But picture still don't import :) – user3622351 Oct 17 '14 at 8:16
  • Another thing is. Not everyone in our company have Picture. So could it be the cause of my problem? – user3622351 Oct 17 '14 at 8:25
  • No, that's not a problem. It doesn't matter whether all user have pics or not. There is something else! Have you check your user profile properties "Picture" is mapped to thumbnailphoto attribute of Active directory – ateet Oct 17 '14 at 10:43
  • Yep, It already mapped with attribute thumbnailPhoto. I can see. Picture-----URL-----thumbnailPhoto. Then I run full sync Then I run "Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation %MySiteURL%" but still don't work. I don't think that I'm missing any step. – user3622351 Oct 20 '14 at 3:26
  • I believe picture imports only work with external identity manager (FIM) and not AD Import option. – bentek Aug 30 '16 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.