0

In SharePoint 2013 Document Library, How to remove name column which is showing always once we upload the document with document name.Name column

5
  • Have you tried to edit the form (NewForm) so that it would not include the "Name" at all? :-)
    – Tenttu
    Commented Oct 13, 2014 at 6:32
  • I'm using SharePoint out of box document library. Could please send me the steps or link so I can try to edit. Commented Oct 13, 2014 at 6:43
  • Here are two guides on how to hide/remove fields from forms with PowerShell: dmcinfo.com/latest-thinking/blog/id/8676/… and microsoft-techies.blogspot.fi/2014/04/… . Also here is some information on how you could maybe apply JavaScript in Newform to hide the desired field: social.technet.microsoft.com/Forums/windowsserver/en-US/…
    – Tenttu
    Commented Oct 13, 2014 at 7:05
  • I hope those guides can give you some pointers! Also I will keep searching and I will let you know if I find out any other information or solutions for you. EDIT: Found one good detailed guide on how to hide fields from NewForm using CSS and Content Editor Web Part: yummyto.com/2014/08/14/… .. :-)
    – Tenttu
    Commented Oct 13, 2014 at 7:06
  • I also found a pre-written JavaScript file that can be downloaded and when used in Sharepoint it will allow customizing the forms: davidlozzi.com/2014/01/14/… :-)
    – Tenttu
    Commented Oct 13, 2014 at 7:18

2 Answers 2

1

You can use powershell script :

Start-SPAssignment -global
$web = Get-SPWeb "Your web adress"
$list = $web.Lists["YourList"]
$field = $list.Fields["Name"]
#This Hides the column in Edit Form
$field.ShowInEditForm = 0;
#This Hides the column in new Form
$field.ShowInNewForm = 0;
$field.Update()
Stop-SPAssignment -global
1

Go to Document Library settings -> Advance settings -> Allow management of content types -> check the box

Now go back to Document Library settings -> Under content types -> click Document content type -> select Name column -> Hide this column

Reference:

http://community.bamboosolutions.com/blogs/bambooteamblog/archive/2013/06/03/how-to-hide-a-sharepoint-list-column-from-a-list-form.aspx

3
  • I already done above steps. After clicking Document Content Type every column is clickable except "Name" column. The link you shared its showing example for SharePoint List however I'm facing issue in Document Library. I am using SharePoint 2013 and in Document Library I'm facing this issue. Commented Oct 12, 2014 at 5:40
  • The reference you call is related to the "Title" field. This is not the "Name". The Name Column seems sealed, or protected.
    – Markus S
    Commented May 18, 2015 at 7:55
  • @MarkusSchmitt true my bad, you can use the above answer. Commented May 18, 2015 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.