2

Am new to SharePoint, Am not a SP developer, i do only administration. My question is very simple and straight regarding configuring a SP application in SP2010.

  1. I created a default application with port 1234 and restored the WSP and content db, and the application is loading internally(inside the server)without any issues after entering the username and password.

  2. To access the application externally from internet, I extended the same application with "Allow Anonymous access" and entered the domain in host header and selected Internet zone, hence extended site is created in IIS, but when i load the application in internet it is STILL prompting for username/password, once i enter the credentials the site is loading with ribbon on top.

Expected Result: To access the application externally in internet without providing username/password/ribbon.

NOTE: If i DISABLE Windows Authentication in IIS Authentication for the extended site, the application is not even prompting for the username/password and throws 401 UNAUTHORIZED error, will this help to narrow down the error?

Am really not sure what am missing here, I followed this article, but i couldn't view the anonymous access button as mentioned in 8th point.

Thanks in advance, Hudson

1

You receive the 401 because SharePoint still expects you to authenticate - so though IIS is passing in IUSR, it doesn't have permissions to logon. You stated you are not seeing the button for enabling site access - and this is what you need before anonymous user can see site content.

From what you describe if you followed those steps you should be ok - but It appears you are missing something. Back in your web app settings be sure to check your anonymous policy and make sure it's set to "none".

You did not explicitly state it - but ensure Anonymous access is enabled in IIS as well.

You made reference to a WSP - bear in mind that any custom code that uses user context will also create your 401 issue, meaning it's not compatible with anonymous access.

  • This point help me fix this issue. "custom code that uses user context will also create your 401 issue, meaning it's not compatible with anonymous access" Thank you very much. – Hudson Oct 20 '14 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.