2

I am trying to bind my SharePoint 2013 to Office Web Apps Server.

The bind works with:

New-SPWOPIBinding -ServerName MyOfficeWebAppsServer

but it doesn't with

New-SPWOPIBinding -ServerName MyOfficeWebAppsServer.mydomain

MyOfficeWebAppsServer.mydomain.it and responds to

https://MyOfficeWebAppsServer.mydomain/hosting/discovery

Is there anyting I could to make it work with mydomain as well?

EDIT: I forgot the error:

WARNING: The server did not respond. Trying again (attempt 1 of 5).
WARNING: The server did not respond. Trying again (attempt 2 of 5).
WARNING: The server did not respond. Trying again (attempt 3 of 5).
WARNING: The server did not respond. Trying again (attempt 4 of 5).
WARNING: The server did not respond. Trying again (attempt 5 of 5).
New-SPWOPIBinding : Sorry, we have encountered an error and New-SPWOPIBinding
has failed. If you are using a server configured with HTTP, you must include
the -AllowHTTP parameter.
At line:1 char:1
+ New-SPWOPIBinding -ServerName MyOfficeWebAppsServer.mydomain
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Microsoft.Share...tNewWOPIBinding
   :SPCmdletNewWOPIBinding) [New-SPWOPIBinding], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewWOPIB
   inding
3
  • not working means...any error?
    – Waqas Sarwar MVP
    Oct 10, 2014 at 15:07
  • I have the same problem... My SharePoint farm is based on Azure, with 4 servers...AD / SQL / SP 2013sp1 / Owa2013sp1. I tried with http and HTTPS (certificates generated by ADCS). Have you any suggestion ?
    – user34202
    Oct 10, 2014 at 18:00
  • #Fabrice Martin check my comments below. Maybe it helps
    – Gyonder
    Oct 13, 2014 at 8:11

4 Answers 4

2

How did you setup your web app farm? If you didn't use the FQDN that is why you can't connect over it. Also check the zone bindings when you bind to SharePoint and make sure you are pointing at the URL where you will access web app farm.

4
  • I used New-OfficeWebAppsFarm -InternalURL MyOfficeWebAppsServer -ExternalURL MyOfficeWebAppsServer.mydomain / -CertificateName “Webapp” . Could you guide me through the process ?
    – Gyonder
    Oct 10, 2014 at 15:28
  • #Jesus Shelby how to check the zone bindings you mentioned?
    – Gyonder
    Oct 10, 2014 at 15:29
  • Get-SPWOPIZone - this will tell you the zone that SharePoint is using to connect to your OWA servers. Get-SPWOPIBinding - this will show all the associations and Zone/Urls configured that SharePoint detected. Make sure you are working with the intended zone that you have configured on the OWA server. Oct 10, 2014 at 15:38
  • Ok, I had Set-SPWOPIZone -zone "internal-https" and then I managed to bind it. It was "external-https"
    – Gyonder
    Oct 13, 2014 at 8:10
0

Add this switch at the end of your command -AllowHTTP. It worked for me.

2
  • 1
    Please consider adding some more explanation.
    – Asad Refai
    Mar 8, 2016 at 17:07
  • 1
    He say about configuring web app server without using https . It will resolve current problem, but it is not recomended to production environment. Apr 4, 2017 at 14:26
0

I had the same issue where the binding worked fine for one environment and it gave error on the second.

Just verify that Excel service and Secure Store service is running on the environment. In my case Secure store service was not running on any server in the Farm. Once I started it on the same server where Excel service was running, the issue got resolved.

0

I installed 4 servers on my domain.

  • First one is for Active directory named "ZARD.shemshal"
  • Second one is SQL server 2014 named "SQL.ZARD.shemshal"
  • Third one is for SharePoint 2019 named "Sharepoint.ZARD.shemshal"
  • Last one is for office online named "Office.ZARD.shemshal".

Now SharePoint is connected to SQL server and everything is working fine. Also I setup and config the office online with no error. But when I try to run "New-SPWOPIBinding -ServerName office -AllowHTTP" on sharepoint 2019 management shell, It bring this error : New-SPWOPIBinding : Login failed for user 'SQL\Administrator'. At line:1 char:2 +

 New-SPWOPIBinding -ServerName office -AllowHTTP
+  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (Microsoft.Share...tNewWOPIBinding:SPCmdletNewWOPIBinding) [New-SPWOPIBindi
   ng], SqlException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewWOPIBinding

My domain is ZARD.shemshal and my admin user is ZARD\administrator. I don't know why it's trying to login with SQL\Administrator . Is there anyone know how I can fix this problem? Thanks in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.