I created a new Managed Metadata Service. I created a new DB for it and new application pool. Everything works just fine from the Central Administration.

However, once I open the Site Settings for the site collection, and I try accessing the Term Store Management Tool, I get this message:

The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator.

Also, there are no choices to choose from the Available Service Applications drop down menu. In other words, my site collection does not recognize the Managed Metadata Service at all.

So how do I solve this?

... If anyone asks, I have only one Managed Metadata Service.

3 Answers 3


OK, it turned out that the Managed Metadata Service was not associated with the web application hosting my site collection. So to fix that, I went to:

Central Administration > Application Management > Configure service application associations

Once there, I found my web application and then opened Application Proxy Group. It turned out that Managed Metadata Service was not checked there. As soon as I included it and clicked OK, I was able to get through the Term Store Management Tool from the site collection Site Settings.


I received this error after running a patch (Dec 2016) on SharePoint. The thing that worked for me is running this in Powershell:


(don't forget to run this first: Add-PSSnapin Microsoft.SharePoint.Powershell;)

Credit: https://www.habaneroconsulting.com/insights/the-managed-metadata-service-or-connection-is-currently-not-available#.WGuwwY3ruUk

Hope this helps! Nick


I got the solution.

Use below given script to create Metadata service.

$MetaSvcApp = New-SPMetadataServiceApplication -Name $MetadataServiceName -DatabaseServer $instanceName -DatabaseName $MetadataServiceDB -ApplicationPool $AppPool

$MetaSvcAppProxy = New-SPMetadataServiceApplicationProxy -Name $MetadataServiceName -ServiceApplication $MetaSvcApp -ContentTypePushdownEnabled -DefaultKeywordTaxonomy -DefaultProxyGroup -DefaultSiteCollectionTaxonomy

When service is created after that follow steps.

Application Management -> Manage Web Applications -> Select Central Admin Web App -> Service Connections and add the new Metadata Service to Web App.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.