2

Unable to register the Workflow Service with SharePoint(HTTP)

When I run the command to register:

Register-SPWorkflowService -SPSite http://servername:port/ -WorkflowHostUri      http://servername:12291/  -AllowOAuthHttp

I get the below error message:

Register-SPWorkflowService : Could not find a part of the path 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\WorkflowActivities'. At line:8 char:1 +

Register-SPWorkflowService -SPSite http://servername:port/ -WorkflowHostUri

... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidData: (Microsoft.Share...WorkflowService:Regist erSPWorkflowService) [Register-SPWorkflowService], DirectoryNotFoundException + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell.Regis terSPWorkflowService

All the required services and app pool are started

Kindly suggest what need to be done to resolve this issue

1

Go to 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\Template\' Copy the 'WorkflowActivities' folder to 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\'

I dont know why the folder is in the 16 hive instead of the 15, but this worked for me.

0

In my case it was enough just to create an empty WorkflowActivities in 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Template\'

0

If the workflow activities folder is missing in the 15 hive, you'll need to copy the directory ( and the .DLL ) file form the 16 hive and place it into the 15 hive.. Creating an empty WorkflowActivies directory may get you past the registration process but it will be a hollow victory.. The .DLL in the workflowactivities directory is what places the workflow actions onto the design surface in SharePoint Designer..

Well the operation of copying the file from the 16 hive to the 15 hive was as success -- but the patient still died. When publishing the workflow, "Error were found when compiling the workflow. The workflow files were saved but cannot be run".. The details [Advanced] Microsoft.Workflow.Client.ActivityValidationException: Workflow XAML failed validation due to the following errors: Cannot create unknown type '{clr-namespace:Microsoft.SharePoint.WorkflowServices.Acvivities} Set WorkflowStatus'. HTTP headers received from the server - blah blah blah.

I expect the there's a strict Strong name match error here someplace. I'll have to poke around in the outline installer files to see if there's anything that looks like it belongs in the 15 hive. I'll also check the .DLL that was moved with ILDASM to see if it's looking for version 16 pieces...

  • Well the operation of copying the file from the 16 hive to the 15 hive was as success -- but the patient still died. When publishing the workflow, "Error were found when compiling the workflow. The workflow files were saved but cannot be run".. The details [Advanced]. – Guy Cox Nov 1 '17 at 18:38
  • The good news is that if you go the V4 GAC and locate the version 15.0 of the .dll and copy it, things will be fine. C:\Windows\Microsoft.Net\Assembly\GAC_MSIL\Microsoft.SharePoint.WorkflowServices.Activities and grab the V4.0_15.0.0.0.0 version and copy it to the 15 hive.. – Guy Cox Nov 2 '17 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.