1

I ran into a weird issue in one of the Site collection on my farm. I have 4 different Web apps and 4 site collections underneath them. Today i tried to browse the top level site of a Site collection , it si throwing http 404 error, whereas on other sites in same server are working fine.

Then i went to manage web application in central admin and looked into the View all Site Collections Link where i found out top level site was missing "/" was missing on top. then i checked other sites underneath that same site collections, they are working as expected.

Then i went to another web application and checked next site collection top level site is there "/".

Is there a way we can receover that top level site of the effected Site Collection.

Thank you

2

Couple of things need clarification:

  1. You said in the web App "/" site missing but other sites are still their, what that mean...other sites mean "/sites/sitename" or subsite of the"/" site?
  2. How many total site collection you can see in that web application.

Possible Solutions:

  1. Make sure the content Database Attached to the web app( the one which having "/" site collection)
  2. If it is deleted accidently then run this command and see if it is still in database...[Get-SPDeletedSite][1] "/"
  3. If above command retrun the site collection then run the below command to restore it.[Restore-SPDeletedSite][2] "/"
  4. Lastly if you have backup of your content database then restore it and recover the root site collection.

Ref:http://technet.microsoft.com/en-us/library/hh286316(v=office.15).aspx

http://technet.microsoft.com/en-us/library/hh286319(v=office.15).aspx

  • For your first question : By other i mean xyz.com/sites/abc, xyz.com/sites/cde are still there and working. Its just "/" missing. – allegro octopus Oct 9 '14 at 18:27
  • I have 15 total site collection under that web app – allegro octopus Oct 9 '14 at 18:29
  • Ok....so clear either you "/" site collection deleted or the db which holding the site collection not attached....did you run the powershell? – Waqas Sarwar MVP Oct 9 '14 at 18:35
  • I went to create site collection and created a top level site using managed path \sites\, issue got resolved. Thanks for your help. – allegro octopus Oct 10 '14 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.