4

The error look like: enter image description here

Is there any one have solutions for this error?

5
  • Are your managed metadata service up and running? Are it still connected to the current webapplication? Are the termset still present? Oct 9, 2014 at 6:21
  • can u tell me how to check it pls. :). I'm fresh to SP Oct 9, 2014 at 6:56
  • From the site collection > go to site settings and look for "Term store manager" and see if you can access the service. And if you can, then look for the term-set that you created your custom navigation in. From central admin - go to manage service applications and click your managed metadata service. Oct 9, 2014 at 6:59
  • Yes. I can see Term Store Management in Site Collection Setting :) Oct 9, 2014 at 7:38
  • Are there created terms in the terms store? If not you might want to considered creating a new MMS and adding to the default service connection. Oct 17, 2014 at 20:30

3 Answers 3

1

To resolve this issue you need to follow below given steps

  1. In ServiceApplications.aspx page select your metadata service and click on properties tab in ribbon.
  2. At the end in Content Type hub property if its null set url Ex: http://sp2013:501/_layouts/15/termstoremanager.aspx
  3. There is a prerequisite for this feature to be activated. Following site collection feature also needs to be activated

-Gear Menu --> Site Settings --> Manage Site Features --> SharePoint Server Publishing

-Gear Menu --> Site Settings --> Site Collection Features --> SharePoint Server Publishing Infrastructure

  1. This is last step. Site Settings -> Navigation -> Create Term Set.

After adding new term, iisreset and then check.

0

I had same error and all i did is, i went to Internet Information Services (IIS) Manager and i restarted Web Server. After restart, menu came back and everything worked fine.

In my case, we had no migration, merge (dev->prod) or anything else. It just popped out and all i did is Web Server restart. Hope it will help someone in future.

0

I went to Gear Menu>Site Settings>Manage Site Features>SharePoint Server Publishing and activated it-- my managed navigation was once again working (on mobile).

Otherwise, navigation was fine on a PC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.