1

I have a requirement to brand SharePoint 2013 MySite. But in order to do that I need to perform Feature Stapling, and that requires Visual Studio installed on the machine that is hosting MySite. I had Visual Studio installed on one of the machines but was having the following error:

enter image description here

So I updated the hosts file as per this article:

http://tszulczewski.wordpress.com/2013/08/15/cannot-connect-to-the-targeted-site-this-error-can-occur-if-the-specified-site-is-not-hosted-on-the-local-system/

But I am having the same error. I am leaning to suspect that SharePoint 2013 MySite is not hosted on that machine. How do I find out what server is hosting SharePoint 2013 site. So I do not get the above error and can use Visual Studio to brand SharePoint 2013 MySite.

Much Obliged.

  • Central Admin -> Manage Web Applications -> SharePoint - MySites .. Check the URL field for the server – Michael Colbs Oct 7 '14 at 20:03
  • @Colbs Thank you for your comment, I do know the url, but cannot figure out the name of the machine that is hosting it. – Aziz Qureshi Oct 7 '14 at 20:11
  • ping the URL, then you can RDP with the IP – Michael Colbs Oct 7 '14 at 20:12
  • how many servers in the farm? what are the AAM settings formysite web applications? – Waqas Sarwar MVP Oct 8 '14 at 2:18
  • I believe we have 3 servers on the farm – Aziz Qureshi Oct 8 '14 at 14:23
2

Are you planning to do Visual Studio development against a production My Site host?

You should not have Visual Studio installed on any of your production SharePoint servers. You should have a development environment and do your work there. Then, when your coding is completed you can deploy your solution package to your production machines via PowerShell or Central Admin.

| improve this answer | |
  • I have visual studio installed on my dev environment. – Aziz Qureshi Oct 8 '14 at 14:22
  • good, then you should be all set. Just go to Central Admin and deploy the WSP. – Derek Gusoff Oct 8 '14 at 16:32
  • does your dev environment have a My Site host? If not, you'll need to create one. – Derek Gusoff Oct 8 '14 at 16:33
0

I finally got VS to connect to mysite. I followed the following site:

http://www.mavention.com/blog/cannot-connect-to-the-targeted-site-error-visual-studio-2012-rc-sharepoint-developer-tools-host-headers

I added my local machine IP address to the hosts file and the site .. so it is (local machine IP address) (site name) (with out the http:// and with out the port number). So if my site is: http://mysiteSomethingSomething.com:101, I put, (local machine IP address) mysiteSomethingSomething.com in the hosts file and saved it.

Thanks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.