1

I have defined a Managed Result Source at the Search Application level of my SharePoint Online tenant and am attempting to run this search using the /_api/search/query REST endpoint. I know this search result works because I am using it well on my sites using the Query Results web parts which are configured using this same Result Source. I captured the ID of my Result source from the URL.

../_layouts/15/searchadmin/EditResultSource.aspx?
level=tenant&sourceid=d0aa2c2e%2D7709%2D46f1%2D835a%2D244f483e4b0e

I then place that ID in the following REST URL in Fiddler

 ../_api/search/query?
sourceid='d0aa2c2e%2D7709%2D46f1%2D835a%2D244f483e4b0e'

The JSON returned is a not a list of the specific content types which I am searching for.

Do I need to add more to the REST query to get it to behave like the Search Results Web Parts do?

  • Does your custom result source contain a query transform that filters on content type(s)? The connection between your result source and the "specific content types" is unclear. – nsturdivant Oct 4 '14 at 15:19
  • Also, have you tried using dashes instead of the URL encoded equivalent? From the MSDN documentation: server/_api/search/…' Source: msdn.microsoft.com/en-us/library/office/… – nsturdivant Oct 4 '14 at 15:25
  • I found the issue. I was not submitting the security cookie with my requests. – ChiliYago Oct 7 '14 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.