I have a dev env where there are 3 servers:

  1. AppServer
  2. WFE
  3. Workflow Server.

i am in a process of installing Sp1 on the SharePoint 2013 Server Standard Edition Env.

When i first ran a Binary file in App Server it completed Succefully. But i encountered a roadblock in WFE, i got following message "An error Occured while Running detection". Then i went though my config and ran this wonderful tool my microsoft ROIScan to get details of my server. it ended up being MArch 2013 PU and October Cu were missing in my server.

Then i downloaded March PU and October CU, i started with March PU but same error message "An error Occured while Running detection", same with October CU.

At that point on i ran Get-Spproduct -local command, to refresh my registry.That didnt work either.

Now i dont have any other options to proceed with this install for upgrade.

What else can be done, can any one help.

I tried to run config wizard without disconnection config db it yells about not having proper patch level in the server.

Thank You

  • i think, this is time to repair the sharepoint on the faulty servers and in worst scenario you have to rebuild the servers which are complain.
    – Waqas Sarwar MVP
    Oct 5, 2014 at 20:30
  • I was able to install Sp1 after Manully extracting all the files in a folder and running all of those patches. Sure it was time comsuming, but i finally got it upgraded. But i am running into the issue that BusinessConnectivity_db didnt get upgraded properly. How shoudl i proceed on that Oct 6, 2014 at 11:52
  • did you run the config wizard?
    – Waqas Sarwar MVP
    Oct 6, 2014 at 12:17
  • Yes I did, which didnt work. Oct 6, 2014 at 12:58
  • completed sucessfully or throws the error?
    – Waqas Sarwar MVP
    Oct 6, 2014 at 12:59

4 Answers 4


This error usually occurs when the Windows Installer cache files (C:\Windows\Installer) are missing/corrupted. To further isolate the issue, you can try running ROISCAN on the machine and see how many installer cache files are missing. If these cache files were deleted manually during any housekeeping, it would be very difficult to restore the files. However if you have any other working environment (test/staging), you can copy the installer cache files and rename it according to the unique revision number from the registry keys associated with it. Luckily I could find a PowerShell script made by Ahmad Adel Gad here which will do this task for you. You simply have to:

  1. Download the script.
  2. Copy the script to the target machine.
  3. Make sure that the current local identity has Read/Write permission on the "C:\Windows\Installer" folder of the target machine, and Read permission on the source folder (If the source is a machine name, make sure you have read permission on the local folder "C:\Windows\Installer" inside the source machine).
  4. Execute the script locally on the target machine with the following parameters as illustrated with the following examples.

    .\Restore-InstallerFiles.ps1 -SourceMachine "Machine1", "Machine2", "Machine3";

    .\Restore-InstallerFiles.ps1 -SourceFolder "D:\InstallerFiles", "E:\InstallerFiles", "\MachineX\D$\MSI Files";

    .\Restore-InstallerFiles.ps1 -SourceFolder "D:\InstallerFiles", "E:\InstallerFiles", "D:\InstallerFiles2" -LogFile "D:\Log.txt";


I fixed the original issue by extracting all the patches using command prompt and manually running all the pathches. After that i ran Sharepoint Config Wizard, which upgrade all dbs except BDC application db. I fix the issue with BDC with Applying SPDATAACCESS role to the BDC database.

  • What order did you follow to install all those patches ? you start from A to Z ? Simply ?
    – Nico
    Mar 30, 2015 at 6:05
  • 1
    Not any specific way, but Yes you can Start from A to Z. Mar 30, 2015 at 13:01

My problem solved when uninstalling MS Office using MS Office easy fix tool then reinstall MS office the error disappear.


By passing in 'PACKAGE.BYPASS.DETECTION.CHECK=1' as a parameter to the update package, you can bypass the package trying to check for a specific version of SharePoint being installed. Example:

ubersrv2013-kb9999999-fullfile-x64-glb.exe PACKAGE.BYPASS.DETECTION.CHECK=1

This solution came from here: http://blog.zebsadiq.com/post/Bypass-version-check-when-installing-SharePoint-CU.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.