4

I m trying to create a new SharePoint app from vs2013.I have the vs2013 ultimate edition and all the needed updates installed.When I press Finish in the process i got this message

enter image description here

One paradox is that I can access the SharePoint site via visual studio server explorer.But when I try to make a new project-app i got this error message no matter if the app is provider hosted or sharepoint hosted

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • I just had this issue. In my case I also had been working on an app that targeted a SharePoint Online site. Then, when opened a second instance of Visual Studio and tried to create an app that targeted a local SharePoint site, I got the error that you described. I tried changing the SharePoint properties as the message described and I got the app built and deployed but it wouldn't run correctly. I guessed that the issue was the other instance of Visual Studio so I shut both instances down and tried again. This time everything worked as expected. – Rob Windsor Oct 3 '14 at 11:17
  • thank you both for your comments. wjervis yes I ve configured it. – g bas Oct 3 '14 at 12:57
  • This error can also happen if using VS 2013 update 4, create new App for SharePoint project (.NET FW 4.5.1), enter your office 365 developer site, select Provider-hosted app, select ASP.NET Web Forms App, select use Windows Azure Access control Service for authentication. – H A Dec 2 '14 at 21:34
  • u need to install microsoft azure tools on visual studio – user39736 Feb 18 '15 at 5:05
0

When creating a new project, enter the URL as https (ex: https://tenantname.sharepoint.com)

Otherwise, if the project has already been created then select the app project's properties. Set the Site URL as an https site.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.