2

I have a page that when we gave it a Name, that name populated both the page title and the file name of the url.

enter image description here

Since we don't use spaces in our urls, the title of the page was populated with the file name...

I'm trying to change the title to say "Search for Classes" but I don't have a field to edit.

I have a Web Part Page Title Bar, but when I edit it nothing happens. enter image description here

What can I do to solve this odd behavior?

EDIT: This is all I get when I look at the site asset library...

enter image description here

  • did you try to go the pages library /the location where page is located...from their click on the page and click on edit properties...you will see title and name their so update the title and then share the result. – Waqas Sarwar MVP Oct 2 '14 at 21:09
  • I clicked on the edit properties, I did not see the title field, just the name field. how do I get it? – Brandon Runyon Oct 2 '14 at 21:34
  • this is webpart page right? you can enter the title in name field so that will be your page name and title....Search For Classes and you url will Search%20For%20Classes. – Waqas Sarwar MVP Oct 2 '14 at 21:43
  • or check the option from this question to change it using deisgner...stackoverflow.com/questions/10799682/… – Waqas Sarwar MVP Oct 2 '14 at 21:56
  • It is a webpart page, but urls with spaces is poor web development practice. we make all the urls to the sites without spaces. – Brandon Runyon Oct 3 '14 at 13:07
2

Goto SiteAssets doc library , find the ICV4... page and edit the "Title" field to "Search for Classes" .

UPDATE :

  1. Goto Site Asset document library settings .
  2. Under Content types ,click "Document" .
  3. Under "Columns" sections the Title field should be changed to "Required" . It is "Hidden" currently that is why you are not seeing it .
  • I don't have a title field in the library item. – Brandon Runyon Oct 2 '14 at 21:27
  • did you click on edit properties? – Waqas Sarwar MVP Oct 2 '14 at 21:33
  • select the page . In the ribbon -> files ->edit properties – Nikhil J Oct 2 '14 at 21:39
  • I go to ribbon, files, edit properties and all I get is a Name field which is a .aspx filename field. I don't know how to change the title. I just have a hard time believing that the url of the page could not be different from the title of the page. – Brandon Runyon Oct 3 '14 at 13:30
  • You can have the page title and url different . did you try the updated option ?? Made change to doc content types ?? – Nikhil J Oct 3 '14 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.