I am sporadically getting errors in my Event Log for SPImmediateAlertsJobDefinition with the ID 6893, I've seen some of the posts out there pointing towards issues with the SharePoint assembly files. Yet I don't think this is the solution since this job runs but only fails say 25% of the time, this is a rough estimate but I do see it run. In Event Log I see the entry for ID 6893, the source is SharePoint Foundation and it comes from the Timer Task Category. Checking ULS I get:

Updates are currently disallowed on GET requests. To allow updates on a GET, set the 'AllowUnsafeUpdates' property on SPWeb.

The Execute method of job definition Microsoft.SharePoint.Administration.SPImmediateAlertsJobDefinition (ID 3b4f3122-46e4-4a9c-952c-a118758f3693) threw an exception. More information is included below. Updates are currently disallowed on GET requests. To allow updates on a GET, set the 'AllowUnsafeUpdates' property on SPWeb.

Exception stack trace:
at Microsoft.SharePoint.SPGlobal.HandleComException(COMException comEx)
at Microsoft.SharePoint.Library.SPRequest.DispatchTimerJob(Int32 lJobType, Guid gVServerId, Int32 lScope, Guid gDatabaseId, String bstrDSNServer, String bstrDSNDatabase, String bstrDSNUser, String bstrDSNPassword)
at Microsoft.SharePoint.Administration.SPNativeDatabaseJobDefinition.Execute(Guid targetInstanceId)
at Microsoft.SharePoint.Administration.SPTimerJobInvokeInternal.Invoke(SPJobDefinition jd, Guid targetInstanceId, Boolean isTimerService, Int32& result)

Far as I know SPWeb should be set. Has anyone found a solution to this or should I just ignore it expecting the next run to resolve the problem?


Sometimes, when doing upgrades, or restoring from back ups, timer jobs aren't migrated correctly and become corrupt.

  • I saw that page and tried some of the solutions, but as I seem to need the Immediate Alerts job (and it only fails some of the time) I did not want to remove it. Finally tried the Repair option, something I had been trying to avoid as I thought all machines in the farm needed it. Sadly, none of this resolved the issue, the same Job still fails sporadically although, at least I know my assemblies are now up to date. – MichaelF Apr 25 '11 at 13:49
  • Accepting this as it seems to be the only lead although I'm still getting these in Production where we've never had restores so I don't think this is the only cause. – MichaelF May 11 '11 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.