0

I have a problem in Sharepoint 2013 which is reproducible.

  1. Create a document library on any site.
  2. Create a folder in this library.
  3. Break inheritance on this folder and add a user that doesn't have access to anything at all, give this user read permissions

Log in as this user and try to go to the folder using the url of the folder. You will get "Access denied".

Although doing the same procedure for a file in the list (upload a file, break inheritance and add a user to be able to read this particular file) works.

4
  • 2
    what template you are using, team site or publishing site?also check if "Limited-access user permission lockdown mode" feature is activated? you can check it under site collection > site settings...
    – Waqas Sarwar MVP
    Oct 1 '14 at 13:51
  • Publishing. So is that feature supposed to be on or off? It was activated, and I deactivated. The error-message was different, instead of access denied it now says "Sorry, this list hasn't been shared with you." Which is interesting, because the list is as it says not shared with that user, but the folder within the list is.
    – Mohag519
    Oct 2 '14 at 6:16
  • We are having the same exact issue. Any luck on it Mohag519?
    – user38976
    Jan 23 '15 at 17:59
  • Justin I am not sure what happened in the end. When my colleague tried the same solution (deactivating the lockdown mode feature) it worked for him, same environment but different user. And also it worked for everybody else so we went with it. Probably some kind of temporary anomaly.
    – Mohag519
    Jan 26 '15 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.