10

Setup:

  • Windows Server 2008 R2
  • SQL Server 2008 R2
  • SharePoint Server 2010

Last successfully installed and configured update: Service Pack 2 for Microsoft SharePoint 2010 (KB2687453).

Current Build: 14.0.7015.1000

Problem:

I'm having a problem running the SharePoint 2010 Products Configuration Wizard. I recently installed the Security Update for 2010 Microsoft Business Productivity Servers. This should bring the build to 14.0.7123.5000. After installing the update, I ran the Products Configuration Wizard. The Wizard failed on step 5 with the following error:

Failed to register SharePoint Services.

I dug deeper into the ULS Error logs and found the following error:

ULS Log Error:

09/30/2014 19:16:57 8 ERR Failed to register SharePoint services. An exception of type System.InvalidOperationException was thrown. Additional exception information: Operation is not valid due to the current state of the object. System.InvalidOperationException: Operation is not valid due to the current state of the object. at Microsoft.Office.HtmlTrans.HtmlTrServiceDeserializationSecurityHelper.EnsureAcknowledgedRunningOnAppServer(Boolean registryKeyLookupResult, ULSCat serviceCategory, Boolean hasExceptionMessage) at Microsoft.Office.Server.Conversions.SPDocConvServiceInstanceUpdaterJobDefinition.UpdateLauncherServiceInstance(LauncherServiceInstance lsi, Boolean fEnableService, Boolean fCycleService, Boolean fCallUpdate) at Microsoft.Office.Server.Conversions.LauncherServiceInstance.Provision() at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstanceInConfigDB(Boolean provisionTheServiceInstanceToo, String serviceInstanceRegistryKeyName, Object sharepointServiceObject) at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstances(Boolean provisionTheServiceInstancesToo, String serviceRegistryKeyName, Object sharepointServiceObject) at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServices(Boolean provisionTheServicesToo) at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.Run() at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

I checked the prerequisites for this particular update and it said SharePoint Server 2010 SP1 and SharePoint Server 2010 SP2 were required. I've installed and successfully configured both of these updates. Unfortunately, I don't understand what the above error means and have been unable to find any resources that have worked so far.

Does anyone have any advice?

  • did you try to restart the server? also try to stop all the services related to SharePoint manually i.e SharePoint timer services, Admin services, Worldwideweb, search , tracing etc from services console. – Waqas Sarwar MVP Oct 1 '14 at 1:51
  • @WaqasSarwarMCSE Thank you for the fast reply. I have restarted the server multiple times. I also tried running the configuration wizard manually from the console using PSConfig.exe -cmd upgrade -inplace b2b -force and it completed successfully. However, the build number did not increase in Central Admin. I'll try shutting down the services manually before running the wizard and report back how that goes. Thanks for the help. – War10ck Oct 1 '14 at 12:39
  • War10ck, Good news and bad news. Good news: I was able to get through the configuration wizard by adding the values you have above as DWORD values in the registry, not as new keys. Bad news: I went down this path because when I try to open a user homepage or central admin I get a 503 and the application pool stops. I've also tried clearing the config cache with no luck. – Joe Meree Jan 13 '15 at 3:36
15

I resolved the issue. It appears based on the Microsoft Knowledge Base information that:

Some document-conversion services in SharePoint Server are not secure when they run in a particular environment

In order to allow the services to continue to run, the following registry key needs to be added:

Name: AcknowledgedRunningOnAppServer
Type: DWORD
Value: 1

to the following locations:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\{version}\LauncherSettings
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\{version}\LoadBalancerSettings

replacing {version} with your version number (14 for me).

After adding these keys, re-run the Products Configuration Wizard and it should succeed.

2

I was still having the same error, even after adding the registry entries.

It turns out that the Net.Tcp Port Sharing Service was disabled, once I enabled it and started, I re-ran the Configuration Wizard again and it went past stage 5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.