2

I have a sharepoint 2013, it is configured for integration mode. From SQL2012, I publish a simple SSRS report to the SP2013. The publish succeeded, but when view the report, it shows this error:

An error has occurred during report processing. (rsProcessingAborted) Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection) Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'.

On the sql server log, it has this error:

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. Reason: Could not find a login matching the name provided. [CLIENT: 192.168.1.91]

The SSRS uses windows authentication. So, I changed it to SQL authentication, it has the same error. Then on SP2013, I changed it to use stored credential, same error.

Weird thing is: it worked before, but I do not know what happened to the server since then.

Anyone have any idea/suggestions?

Thanks

2

Do you have anonymous enabled on your web application? If so then this will happen even if the site you are using SSRS on doesn't have anonymous enabled.

The way we get around this is to extend SharePoint to another web site in IIS and turn off anonymous for that zone/web site. We then have two urls to our site:

https://site.company.com (anonymous) and https://reporting.site.company.com (NOT anonymous)

When we use report builder or when creating datasources, we use the https://reporting.site.company.com url. By doing it this way you can still view and interact with reports from the https://site.company.com url without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.