I am unable to start the SharePoint search host controller service though I run the services.msc as an administrator.

When I am trying to update a list item, I am getting the following error.

The server was unable to save the form at this time. Please try again.

Update 1:

This is how my service looks like right now: enter image description here

As you can see that the Log On As is set to Network Service.

Will this be an issue?

2 Answers 2


Make sure that the service for search host controller is run under the correct domain account. Make sure its an account that has enough credentials and that the password does not expire! also make sure its a managed account within central admin

for details on managed accounts and password change: Click here

make sure that the account that your using is part of the local admin group as well!

goto users and computers to add the managed user account to wss_admin_wpg

Go to "active directory users and computers" -> select the account that is a domain account that is used for the service -> right click the account and select "add to group" -> click advanced and search for wss -> it should show three groups... You need to select WSS_ADMIN_WPG and click OK -> OK and now it should have correct access.

what version of SharePoint your using?

as for changing the account or checking:

goto services.msc -> goto the service in question -> right click and select properties -> within the new popup select on "log on" tab -> change to an account that has the right privileges to run that service!

so what have we done?

1) made sure the account were using is managed within central admin so that password is auto changed and doesn't effect services and is now accessible when creating services through central admin to be selected as a service account

2) made sure it has the correct privileges on the server to run the queries or anything that needs elevated rights or resources only available as admin on the local server like local resources

3) changed the service to use the new account or updated account if it is not the correct one!


you can use the network account but it would still need the right privileges and is not adhering to best practices... you should have a new account that is a service account specific to search. please refer here

as noted the account Network Service doesn't have the right privileges and ideally you shouldn't elevate its privileges but rather create a new account through central admin and add it as a service account -> make sure its part of wss_admin_wpg and then change the service to this new account and do an iis reset and all should work fine!

  • Please check my update above.
    – riz123
    Sep 29, 2014 at 9:54
  • well my sharepoint version is :
    – riz123
    Sep 29, 2014 at 12:10
  • thought so, just asking to make sure the info is correct to the question! Network service is out of the box account that is set by default with limmited access that the search service cant be set to as it needs more elevated access, you need to change as stated in my answer! let me know if you get stuck i will try to help as best i can!
    – Ali Jafer
    Sep 29, 2014 at 13:13

The most common cause for that , that I've found, was sharepoint being installed on the box, but the service instance being in a disabled state.

Get-spenterprisesearchserviceinstance -identity <servername> to confirm

if disabled, do $ssi = get-spenterprisesearchserviceinstance -identity servername>

then $ssi.provision()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.