0

I'm creating new Sharepoint site. I created a custom masterpage. I added webparts in my page. I'm login with system account and my webparts are visible. Then I'm login with another account, but my webparts disappear. And my styles are distoring. I check out my styles but it doesn't solved. Screenshots are as follows.

Please help me. Why are these broken?

enter image description here

enter image description here

enter image description here

enter image description here enter image description here

enter image description here

4
  • Please make sure to check in and publish all your modified files and pages Commented Sep 26, 2014 at 5:41
  • @RobertLindgren I check it my css files but it doesn't solve. How can I publish pages and files? I checked its only.
    – zengel
    Commented Sep 26, 2014 at 5:47
  • I check it my css files but it doesn't solve. How can I publish pages and files? I checked its only. @RobertLindgren
    – zengel
    Commented Sep 26, 2014 at 5:49
  • Google is your friend : office.microsoft.com/en-us/sharepoint-server-help/… Commented Sep 26, 2014 at 5:59

2 Answers 2

2

Changes that you make from one account will not be visible to others unless you publish those files, so just publish your css or any other file in which you made changes. and for the webparts that are getting disappeared, the issue could be that the user from which you are trying to view them may not be having permission for accessing them.(for example if you are using a content editor webpart and referring a text file for which the user is not having permission to read in that case user would not be able to access the webpart. )

To publish just select your file and from ribbon select the "Files" tab and from the commands select "pubish"(perform this action from the account using which you have made changes to that file). after that changes would be reflected to other users as well.

For the webpart error just check the necessary permissions for any file,list referenced by the webpart.

0

we need to know a few things before we know exactly what is going on here. More than likely you havent done the whole process of checking in the page.

I presume that the masterpage that its using is old? as you are refering to a custom masterpage that is not showing the webparts within the page with distored css.

so, 1 goto the masterpage location and make sure you check in the masterpage, once checked in you then also need to, approved and then publish publish that custom masterpage before anyone with limmited access would have visibility to that masterpage.

where is your css store?

next part is your layouts, i presume you added the webpart to the page? if you you also need to publish that page. Within the page you edit the page... add the webpart and ammend the webpart. Next you save the page (check in). This is a draft version visible only to you at the moment so you need to publish the page by creating a publishing workflow. I dont know what version of sharepoint your using: for 2013:

http://office.microsoft.com/en-gb/sharepoint-help/save-and-publish-pages-on-your-website-HA102823156.aspx

2010

http://office.microsoft.com/en-gb/sharepoint-server-help/work-with-pages-in-a-publishing-site-HA010099663.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.