I've migrated our SharePoint 2010 solution to SharePoint 2013 following these steps:


After a lot of pain and heart ache, I managed to get the solution compiled and deployed (using VS2013) into my local SharePoint 2013. The Feature is visible from the Manage Farm Features and can be activated/deactivated. All file references use the SP2013 v15 DLLs. I've changed references in the code as per article - although there were over 1000 lines of code to changes in .cs and .aspx files.

However, it does not appear in the Site Features, ie:


When comparing the Package.package settings between SP2010 and SP2013, only the SharePoint version has changed from 14 to 15.

The Feature's scope is set to Web which is the same as the SP2010 version. The Feature property "Is Hidden" is also set to False.

Install-SPFeature -ScanForFeatures yields no results.

I am running SP2013 on a Windows Server 2012 R2, with VS2013 Update 3. This is a clean install and has had no prior versions of SharePoint on. I'm just looking to upgrade the solution from 2010 to 2013.

I just need to know where to start looking into this issue. Please add a comment if there is more information you need on this.


I've reinstalled SharePoint 2013 SP1 with the Farm option (I think I'd had it to Standalone initially).

Now I have the converted solution. When I deploy now, I get the message:

Error occurred in deployment step 'Activate Features': Feature with Id 'Some GUID' is not installed in this farm, and cannot be added to this scope.

The same effect is that it is not deployed to my default Web. I can see in Solution Management that this is deployed to my default web ie:


Now I have created a new SharePoint 2013 solution in VS2013 with a single Feature of which the scope is set to Web. I have not set anything additional on this project. When I deploy this from right-click Deploy in Visual Studio, I get the same error message above for GUID d06492f1-d4ba-41a4-b9ad-76fb34a4cccd.

Now I cannot get simpler than that for a SP2013 solution to deploy to a Web target.

The solution appears in the Solution Management in Central Admin where it reads Globally Deployed.


I've broken the deployment down to 2 powershell scripts to rule VS2013 out. I get the same error from the following:


$solution = "MyFirst2013App.wsp"
$fullPath = "E:\Publish\" + $solution

Add-SPSolution $fullPath
Install-SPSolution –Identity $solution -GACDeployment -Force  

Enable-SPFeature -Identity d06492f1-d4ba-41a4-b9ad-76fb34a4cccd -Url "http://devvm005"

It is still complaining about GUID d06492f1-d4ba-41a4-b9ad-76fb34a4cccd. You can see the Feature files under C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\FEATURES\MyFirst2013App_Feature1.

Looking at the Solution Properties under Central Admin:




Given that I have tried it on my machine, I have now tried the PowerShell scripts on a Server 2008 R2 Standard with SQL Server 2008 R2 (separate machines) environment. I get the same error.

Further to this, I have created a SharePoint 2010 Project on a different server whilst doing the same for SharePoint 2013 - both using VS2013 Update 3. VS2013 is installed on the SharePoint server.

So, In VS2013:

  1. File->New->Project

  2. SharePoint 2010 - Empty Project

  3. Click OK

  4. SharePoint Customization Wizard dialog

4a. Select Deploy as farm solution

4b. Click Finish

  1. Right click on the Features folder and select Add Feature from the popup menu

  2. Double click the new Feature1 that was added to show the properties window

  3. Set the version to

  4. Right click on the SharePointProject1 and select Deploy from the popup menu

I do this on the 2 different machines. SP2010 deploys ok, whilst SP2013 fails.

2 Answers 2


OK. After much beating around the bush, it was suggested about changing the Template Selection Experience Version.

This is when you setup your Site Collection.

Site Experience

Well, I wasn't too keen on the SharePoint 2013 look and feel (This may take some getting used to) so I set it to SharePoint 2010 Experience.

However, I deleted the existing Site Collection that was set to be SharePoint 2010 Experience and created a new one with 2013 Experience.

Right click on the solution and Deploy - and lone behold - it deployed without a problem. After finally finding how to get into the site settings, the Site Features that I was trying get deployed from the initial root cause of this forum post were in there. Magic.

enter image description here

So the bottom line is you cannot deploy a 2013 solution onto a SP2013 2010 Experience site collection.


In case someone else happens upon this discussion, be sure to check out this link. It explains the significance of sharepoint 2010 compatibility and how to deal with it.


Deploy custom features to upgraded site collections in SharePoint Server 2013 SharePoint 2013

Applies to: SharePoint Server 2013 Topic Last Modified: 2014-09-05 Summary: Learn supported scenarios for deploying custom features to upgraded site collections in a SharePoint Server 2013 farm that has been upgraded from SharePoint Server 2010. This article describes how to deploy custom features through solution packages to a SharePoint Server 2013 farm that has been upgraded from SharePoint Server 2010. It includes information and procedures for supported scenarios. It also introduces feature masking. In this article:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.