0

First of all I have 2 virtual machines, one for the Active Directory and the other one for SP Server and SQL server together. I've come across a handful of posts regarding KB934525 for Windows SharePoint Services and failure to start the Windows SharePoint Services Administration service. I found some solution concerning this failure but I have tried the option 1,2 and 4 and neither of those worked. I have read also that normally if there is a failure to start the Windows SharePoint Services Administration Service, I can’t access the Central Administration. However the Central Administration works perfect for me.

Here are the solutions that I found :

      I've attached some basic troubleshooting steps that may provide resolution to issues
     where psconfig fails with Cannot start service SPAdmin on computer '.'.  For those who have installed the KB and have experienced issues where the service has failed to start, Option 4 is the recommended solution. 

        UPDATE Oct. 15, 2007 18:50 If you are unable to successfully initialize and complete the SharePoint Products and Technologies Conf

iguration Wizard (psconfig) after following the steps in Option 4 below, consider Options 1 through 3; otherwise, uninstall WSS from the server, reinstall WSS, extract the contents of the KB using the steps provided in Option 3 below and install from the extracted STS.msp and following the remaining steps in Option 4 to start SPAdmin and complete configuration.

    UPDATE Oct. 16, 2007 13:15 I received information indicating you may also experience the attached error in your server farm to which Option # 4 resolves:

    The schema version (3.0.149.0) of the database WSS_Content_<databasename> on <databaseserver>\<instance> is not consistent with the expected database schema version (3.0.151.0) on <database>.  Connections to this database from this server have been blocked to avoid data loss.  Upgrade the web front end or the content database to ensure that these versions match.
    UPDATE Oct. 23, 2007 14:52
    See below on steps to resolve The database WSS_Content on HOME\Microsoft##SSEE is not accessible to missing Windows Internal Database signatures.

    Option # 1 

    •   Start the Windows SharePoint Services Administration service using the Services applet (Start, Run, Services.msc) and run SharePoint Products and Technologies Configuration Wizard.

    Option # 2 

    •   Start the SPAdmin service under the context of a local administrator on the server where the SPAdmin service failed to start when running the SharePoint Products and Technologies Configuration Wizard (psconfig.exe) and run SharePoint Products and Technologies Configuration Wizard.
    net start spadmin

    Option # 3 

    •   Download wssv3-kb934525-fullfile-x86-glb.exe fromhttp://www.microsoft.com/downloads/details.aspx?familyid=76FC2225-2802-46E5-A294-A842E3841877&displaylang=en.
    Extract wssv3-kb934525-fullfile-x86-glb.exe and run the installation by executing C:\temp\STS.msp (see below). 

    <drive>:\wssv3-kb934525-fullfile-x86-glb.exe /extract:c:\temp.

    Option # 4 

    •   On the machine where psconfig failed to start the SPAdmin service run:
    %commonprogramfiles%\Microsoft Shared\Web Server Extensions\12\BIN\psconfig -cmd upgrade -inplace b2b -wait -force
    Modify the service timeout values in the Registry:
    HKLM\SYSTEM\CurrentControlSet\Control add/modify DWORD value ServicesPipeTimeout to 60000 (60 seconds) 

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control add/modify STRING value WaitToKillServiceTimeout to 120000 (120 seconds)
    Restart the server machine.

How I would start correct the Windows SharePoint Services Administration service?

Thanks you in advance.

1 Answer 1

0

I'm assuming that you have performed the steps, if not then do these steps:

  1. Run services.msc and start Microsoft.SharePoint.Administration service.
  2. Make sure Administration services is running and configured as 'Automatic'.

Note:- Make sure that you are running the services under Farm account credentials. And start the services in VM where SharePoint and SQL are installed.

Try the things mentioned above. Maybe that help you.

1
  • I have tried the things you proposed me but nothing changes The message below still appears in my screen. "The Windows SharePoint services Administration service on local computer started and stopped.Some services stop automatically if they are not in use by other services or programs"
    – Galactika
    Sep 26, 2014 at 9:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.