0

I've created a Search Center site collection at mycompany.net/intranet (Enterprise Search template) and it worked just fine.enter image description here

I've config to search in mycompany.net site collection, and it work OK. enter image description here

when I go to setting, and choose Search Setting and specify http://mycompany.net/intranet in Search Center URL. Then I go back to mycompany.net and select search for everything,people or conversation, Instead of display the result, this page display like this.(If I choose This site, it work ok).

enter image description here

enter image description here

  • Are you sure that you go to "Search settings" under site collection administrator features? – Christoffer Sep 25 '14 at 7:48
  • yes, i'm sure that – user3622351 Sep 25 '14 at 7:54
  • And you are sure that you have configured it correctly? At the search center Url, did you type the adress to your search site collection followed by "/pages" ? – Christoffer Sep 25 '14 at 7:58
  • my root site is mycompany.net and my search site collection is mycompany.net/intranet . And I type "mycompany.net"/intranet in search center Url. – user3622351 Sep 25 '14 at 8:05
  • Are you using managed paths? What is the internal url for the search site collection? (sites/search)? – Christoffer Sep 25 '14 at 8:10
1

Make sure that you type correct URLs in the search settings. The search center url must be followed by /pages so an example would be http://server/sites/search/pages.

The same goes out to the setting to send a users query to a custom result page. Then /pages/results.aspx" must be added to the rest of the URL, like this example: http://server/sites/search/pages/results.aspx

In your scenario it would be http://mycompany.net/intranet/pages and http://mycompany.net/intranet/pages/results.aspx.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.