0

we're getting some ... interesting ... behavior in IE.

Setup

We have a page layout based on some content type. Both contain (besides other fields) a DateTimeField which is shown in edit mode.

When a user clicks "Save" after editing the page, he is presented a modal dialog saying "Are you sure you want to leave this page?" with the options to "stay" or "leave".

When a user clicks "leave" the following behavior is as expected (changes are saved, page is working). When a user clicks "stay" he sometimes gets prompted for conflicts.

As soon as the DateTimeField is removed from the page layout (but is kept in the content type) there are no more such pop-up dialog.

This happens only in IE 9/10/11. FF and Chrome work fine.

Do you have any suggestions, on how to fix this? Not the conflicts part, but the fact that this dialogue box is shown at all.

Ben

Code

Field Definition

<Elements xmlns="http://schemas.microsoft.com/sharepoint/">  
  <Field
       ID="{401b4dad-f4db-45a8-a111-42ed278a3298}"
       Name="FI_Erstellungsdatum"
       DisplayName="MyDate"
       Type="DateTime"
       Required="TRUE"
       Group="MyGroup" 
       Format="DateOnly">
    <Default>[Today]</Default>
  </Field>
</Elements>

Reference in Content Type

<FieldRef ID="{401b4dad-f4db-45a8-a111-42ed278a3298}" DisplayName="MyDate" Required="TRUE" Name="FI_MyDate" Format="DateOnly" />

Reference in Page Layout

<SharePoint:DateTimeField FieldName="401b4dad-f4db-45a8-a111-42ed278a3298" runat="server"></SharePoint:DateTimeField>

Internet Explorer

I already tried seeting IE (Security) Settings back to deafault and disabling add-ons. It did not help.

The site is accessed via https and is in the Trusted Sites list in IE.

0

Try the methods listed below

Method 1:

Step 1: Change Internet Explorer Security settings Link

Step 2: Add the website to trusted websites list. Link

Method 2:

I would suggest you to run the Internet Explorer in no add-ons mode and check if it helps. To do so follow the step 4 from the below link: Link

If that does not work, follow all the troubleshooting steps mentioned in the above link. Note: The Reset Internet Explorer Settings feature might reset security settings or privacy settings that you added to the list of Trusted Sites. The Reset Internet Explorer Settings feature might also reset parental control settings.

You may also refer the link: Link

This message appears in two different situations:

a) When you are trying to access any secured website

b) If you leave a page or try to close the page in the middle of composing an email. It is made by design and you will get the prompt by default if you perform any of the above things.

  • Concerning step 1) I tried setting the IE Security setting back to default, but it did not chanfe the behaviour. Furthermore, I don't want to mess with these settings as the Site will be deployed to a corporate intranet. Concerning step 2) The website already was part of the trusted websites. Concerning method 2) I reset IE back do all defaults and also disabled add-on, but it did not change a thing. I feel like this is specific problem of IE + SP 2013 + DateField. – ben Sep 23 '14 at 7:25
  • I think is is the some problem with browser, anyways will check some more solution if i get and update you soon. – Hardik Kothari Sep 23 '14 at 7:38
  • The problems in reproduceable on different machines in different companies. It's not specific to my machine. – ben Sep 23 '14 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.