1

I have create a custom field type. I can add/edit/delete without any issue.

However when I click on the column header name to filter, it shows me the error message

Cannot show the value of the filter. The field may not be filterable, or the number of items returned exceeds the list view threshold enforced by the administrator.

1
  • that is because sharepoint doesn't know how to filter your custom field type. what kind of field is it?
    – Gwny
    Sep 22, 2014 at 10:53

1 Answer 1

1

Only fields you can filter or sort are the ones you enable indexing attribute on.

You can either do it in code or by going to list setting and enable indexing on that specific column.

SPSite site = new SPSite("http://localhost");
SPWeb web = site.OpenWeb();

SPList custList = web.Lists["Customers"];
SPField custPhone = custList.Fields["Phone Number"];

custPhone.Indexed = true;

Reference

1
  • OP can not filter, so since "Only fields you can filter or sort are the ones you enable indexing attribute on." he shouldn't be able to enable indexing on the custom field? How is this an answer the the problem?
    – Alex
    Oct 9, 2019 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.