1

I am using sp2013. I have a document library where I have full control permissions. I have set for my self the email alert for new documents and updates. When I add a new document or update an existing document I dont receive an email. The email is correct because I receives an email when I was setup the email alert.

I have also created a new document library and a list. Same issue. Other users has the same issue.

What is going wrong? How can I find out where the issue is?

Update:

Other webapplications are working fine.

Update 2:

The webapplication where I have this issue, is not for the whole webapplication. It looks like on site collection level. The root site collection of this webapplication is working fine. I have this issue on a sub site collection.

4
  • I had the same issue before. Is this in a upgraded environment? (2010 > 2013) Sep 22, 2014 at 9:39
  • yes this is upgraded from 2010 to 2013. Do you have a solution?
    – Ola
    Sep 22, 2014 at 11:06
  • is this behavior with one users on that site collection or with all users?
    – Waqas Sarwar MVP
    Sep 22, 2014 at 15:38
  • I have same problem for my SP2010. The funny thing is only some new users not work. All old users no problem.
    – Mark L
    Apr 19, 2017 at 8:24

2 Answers 2

1

It can be possible that not working one WFE server may cause problem.

So best solution will be to check whether alerts mail are triggered from SharePoint is to check drop folder in smtp server. There you can find mails from SharePoint Alerts if these mail didn't reach to you.

Path will be C:\inetpub\mailroot\Drop

Also, check folder C:\inetpub\mailroot\Queue, if you find your alerts mail there.

Check this folder C:\inetpub\mailroot\Queue\Badmail, for any errors regarding your mail.

These are paths within your SMTP server.

0

I had the same problem after doing a migration from SharePoint 2010 to 2013.

I did get emails for setting up alerts, but never any actual mail when an item was added or updated. So i guess that there were something wrong with the alert permissions after migrating from 2010. Disabling and enabling the permissions on the web application level sorted it out.

Go to your web application in central admin, select the web application and then select permissions and deselect Create Alert and Manage Alerts. Click ok. Do the same again but this time enable them. After that it took like 30 minutes but after this the emails for my web application started to work.

( Create Alerts - Create alerts and Manage Alerts - Manage alerts for all users of the Web site. )

Alerts on upgraded Sitecollection, 2013

4
  • what do you mean with this? Create Alerts - Create alerts and Manage Alerts - Manage alerts for all users of the Web site. Do I need to remove all the current alerts? And create new ones? And do I need to disable email alert in the central admin, select web application, go to general settings?
    – Ola
    Sep 22, 2014 at 11:28
  • See my updated answer. Sep 22, 2014 at 11:34
  • Did you have any luck trying it out? Sep 22, 2014 at 12:43
  • no it dousnt work:( I have a farm with 6 front end servers. 5 front end servers I can connect to the smtp server by telnet. Only one it dont work and gives me: Connecting To smtp.myCompany.biz...Could not open connection to the host, on port 25: Connect failed. Should this be the issue?
    – Ola
    Sep 22, 2014 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.