3

No matter what I try, I keep on getting the yellow triangles with the message "Intellisense was unable to colmplete an accurate...". For example when I type "SP." then among others ClientConetext does show up, but with a yellow triangle and the above message.

Googling gave me all sorts of different possible solutions but nothing works. So what do I put where exactly in my Visual Studio SprepointApp project????
1) Which script links do I put in the default.aspx page exactly?
2) What exactly should be in my reference.js file??
3) What exactly should be enabled in the Tools-->Options-->Text
Editor
>JavaScript_>Intellisense->Reference menu??

Please help me out here since this costed waaaaay to much time already...

Edit: what I have now: In my reference file I have:

/// <reference path="jquery-1.8.2.js" />
/// <reference name="MicrosoftAjax.js" />
/// <reference path="../_layouts/15/init.js" />
/// <reference path="../_layouts/15/SP.Core.js" />
/// <reference path="../_layouts/15/SP.Runtime.js" />
/// <reference path="../_layouts/15/SP.UI.Dialog.js" />
/// <reference path="../_layouts/15/SP.js" />

Please note I have "../" instead of "~/" since the latter won't work either.

Edit2: jQuery Intellisense works fine. It's all about the SP.js intellisense...

3 Answers 3

3

OK, so finally I figured it out...

1) In Tools-->Options->Text Editor->Javascript-->intellisense-->references the path to my "_references.js" file in my project was missing. I added the relative path to it ("~/Script/_references.js")

2) Also the "~/_layouts/15/" part of the path's in the references.js file itself are not working for file "~/_layouts/15/sp.debug.js"(no clue why, same problem occurs in the default.aspx file, where I had to replace al the "~/" with "../". To overcome this I recreated the sp.debug.js file which I found at https://.sharepoint.com/sites/devloper/_layouts/15/sp.debug.js

3) Copeid the code and created a new sp.debug.js file and added it to the Script folder in my project in VS2012.

4) I added the following reference to my _references.js file:

/// <reference path="sp.debug.js" />

And now it works :)

2
  • Hi Tomvanderhoek, Thanks for sharing this tips. sp.debug.js did the trick for me... Feb 20, 2015 at 14:24
  • Great, thank You Tom! Adding references in Options + Copying from "C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\LAYOUTS\SP.debug.js" to local "Scripts" helped!
    – Gennady G
    Dec 19, 2016 at 11:37
1

try without "15" in the path

/// <reference path="../_layouts/init.js" />
/// <reference path="../_layouts/SP.Core.js" />
/// <reference path="../_layouts/SP.Runtime.js" />
/// <reference path="../_layouts/SP.UI.Dialog.js" />
/// <reference path="../_layouts/SP.js" />
0

Try this url having description that how to enable intellisense in VS2012 http://code.msdn.microsoft.com/office/Enable-ECMA-Client-Object-28e112cd

1
  • yas, saw that, but still not working :(. I have the _reference.js file in my project already with those lines. In fact, this is in my reference file: < /br> Sep 21, 2014 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.