2

I'm trying out the Recycle Bin REST API endpoints for Sharepoint mentioned here . The URL I'm hitting is;

https://tenant-my.sharepoint.com/personal/username_tenant_onmicrosoft_com/_api/web/RecycleBin

I'm getting an empty list for a response, even though the recycle bin is full of items.

Response:

{
"d": {
    "results": []
     }
}

Am I missing any configuration?

  • I'm encountering the same issue. Did you find a solution for this? – Dr Potato Dec 2 '14 at 3:13
  • Nope! The information wasn't enough to reach a conclusion. So I decided to skip this portion. – Syed Mauze Rehan Dec 2 '14 at 5:58
  • @SyedMauzeRehan This might be from a little while ago, but did you end up finding a workaround for this? – vinod Sep 24 '15 at 3:50
  • No. Just tried again to see if it started working. I am now using Client Credentials Flow to get access token and still no luck. I had assumed that it was a permissions issue or something (as I was using Authentication Code Grant Flow previously) – Syed Mauze Rehan Oct 1 '15 at 6:57
0

I was having the same issue and was able to resolve it by changing the credentials for the HTTP Request step within the Flow. It doesn't really add up, given that the accounts for the step's original and newly assigned credentials both have access to the site collection's Recycle Bin. It's worth a try, though, if you're seeing the same issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.