4

I face this issue frequently when using Designer. When opening Designer it shows the following error:

enter image description here

4 Answers 4

3

As per you query, the issue is inconsistent. So you can try following to get it resolved:

As per Microsoft:

This issue occurs because anonymous authentication for the SharePoint web application that hosts the SharePoint site is disabled in Internet Information Services (IIS).

The Windows Communication Foundation (WCF) runtime requires that the security settings of the WCF service match the IIS settings. When anonymous authentication is disabled in IIS, WCF cannot use anonymous binding. Therefore, the WCF runtime throws an exception if there is anonymous binding in WCF.

Web applications use a claims-based authentication method. Therefore, the identity of web application threads is forms-based instead of Windows-based. When a Windows-based user identity is not used and WCF binding is not anonymous, the WCF runtime throws an "Access denied" error. Additionally, a 302 error code is returned to the logon page.

To resolve this issue enable anonymous authentication for the SharePoint web application in IIS.

http://support.microsoft.com/kb/2758431

Also you can try:

http://www.c-sharpcorner.com/UploadFile/anavijai/error-the-server-could-not-complete-your-request-when-tryi/

http://www.brightworksupport.com/error-when-opening-site-in-sharepoint-designer-2013/

1
  • i have tried this. its not working that way. not getting the root cause for this. Sep 20, 2014 at 9:35
1

I faced an issue recently and would like to post it here for future reference.

This issue appeared to be random and related to the infrastructure, but the fact that it only happened with specific files caught my attention.

Long story short, the issue was related to javascript validations, probably post-updates, and was fixed by removing the spaces between "function" and curly brackets as suggested below:

Replace:

" () {" by "(){"

and

") {" by "){"

For my full blog post, please check here,

SharePoint Designer | JavaScript changes causing SPD to hang

0

I disabled Asp.Net Impersonation authentication on the IIS web app and it seems to work.

1
  • Could you extend the answer? Thank you
    – Benny Skogberg
    Aug 10, 2016 at 8:56
0

Disable Asp.Net Impersonation authentication at the IIS. Go to IIS, find the sharepoint website. Click Authentication. Enable the anonymous. At the anonymous entry, click "Edit". Set the anonymous user identity to application pool identity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.