1

I am trying to obtain a calculated column with ISBLANK

=IF(ISBLANK(AuthorTxt) , Title ,  Title + " " +  AuthorTxt)

as suggested here

but I get a syntax error or not supported formula message. Why is it wrong? Is there another way to do it?

2
  • Are you using english version of sharepoint? Sep 19, 2014 at 9:15
  • no.I translated the message myself
    – Gyonder
    Sep 19, 2014 at 11:29

2 Answers 2

4

Regardless of which character is used when the field is created, the formula works on lists in SharePoint websites anywhere in the world. SharePoint automatically changes the delimiter character to the one that is appropriate for the language/culture of the current page. In some countries, the comma is reserved for use as the decimal mark. In such countries, users creating a calculated field must use semi-colons ";" as the delimiter character. For example, suppose the following formula is created on a website whose culture setting is fr-fr (France): =IF(Number1>Number2;5;10). If the website's culture is then changed to en-us (United States), the formula changes automatically to: =IF(Number1>Number2,5,10).

And if your locale uses not latin characters, the all the formulas have to be different. Best way is to validate formula in Excel with your current locale.For example in russian locale =ISBLANK() equals to =ЕПУСТО()

3
  • thanks.Now I see why you asked about translation. Anyway, I have latin characters and had the formula translated as well.
    – Gyonder
    Sep 19, 2014 at 12:26
  • That worked well!
    – lex
    Sep 29, 2015 at 21:21
  • Late to the party, but I've been on that for hours, so thanks a lot. I would have never thought about localization being the problem. That's... quite stupid of a design choice if you ask me.
    – Kilazur
    Dec 21, 2015 at 14:20
0

Please maintain proper code syntax.

You should note, it may have trouble parsing the text.

You need brackets, and don't try to join strings together without concat.

Try this:

=IF(ISBLANK([AuthorTxt]),[Title],CONCATENATE([Title]," ",[AuthorTxt]))
1
  • No, you only need brackets when you have spaces in the Fieldnames. On save SharePoint will delete all brackets in the formula. OPs problem is with the commas, he has a russian site and needs to use ; (semi-colon) as function-parameter separators as the comma is for number notation (on non-english sites) Jan 24, 2015 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.