0

I am editing a publishing page on SP2013 farm. After adding a simple table and save, the spell checking found many mistakes (which I am sure no mistake) and update my html. Hence I cannot save a normal HTML table.

  1. What can I do to disable spell checking?
  2. If not, any work around?
1

For the longest time I have really overlooked the spell checking functionality in SharePoint. This was mainly due to my unreliable experiences with it on publishing pages. Each time I checked in a page it was common to receive a dialog reporting a huge number of spelling errors.

enter image description here

But I KNOW that this page is a masterpiece, how could there possibly be 105 spelling errors? Well a bit of Googling brought me to an article written by Morten Schioldan – http://blogs.msdn.com/b/mortens/archive/2011/12/09/gazillion-spelling-errors-on-blank-pages.aspx

This article indicates that the contact field control was the cause for these errors. If a contact field is included in a page layout the spell checker runs over the code for this control rather than it naturally getting excluded.

This is where JavaScript comes to the rescue. In the page layout wrap your contact field with the following div.

<div id="excludeContentFromSpellCheck">
[FORM FIELD HERE]
...
</div>

Next step is to add the following JavaScript at the top of your PlaceHolderMain:

   <script type="text/javascript">
      window.onload = function()
       {
                       var a = document.getElementById('excludeContentFromSpellCheck');
 
        var b = a.getElementsByTagName('input');
        for (var i = 0; i < b.length; i++)
 
         {
              b[i].setAttribute("excludeFromSpellCheck", "true");    
         }
 
         var c= a.getElementsByTagName('textarea');
         for (var i = 0; i < c.length; i++)
 
         {
              c[i].setAttribute("excludeFromSpellCheck", "true");    
         }
 
                };
        </script>

Source: http://blog.cube4.com.au/?p=1016

  • Please do not post link only answers. Instead post the details here and then use the link as a source. If the link breaks your answer will be of no help to future readers – Skaft Sep 18 '14 at 7:55
  • Sorry, I've already edited my post – Aventus Sep 18 '14 at 8:01
  • Thanks. I have visited the source site before but I could not apply to my situation. I just create a new page and no contact field. Do I need to modify my Master page to wrap entire page with excludeContentFromSpellCheck? – Mark L Sep 18 '14 at 15:35
0

Actually I worked around it by renamed these 3 files:

  • SpellCheck.asmx
  • SpellCheckdisco.aspx
  • Spellcheckwsdl.aspx

under C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\ISAPI to whatever filename. It breaks the Spell check web service. The spellcheck window still prompt up but it will always find zero error.

However I still want to disable the Spellcheck prompt dialog. Entire spell check function just a mistake.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.