0

I have a WCF service deployed in IIS Website. I am able to invoke the service from web browser using service url -

  http://localhost/Service.svc/get/hello


It returns data in XML format as desired -

  <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/">hello</string>



What I need is to use the service in SharePoint workflow using the 'Call HTTP Web Service' action. I am specifying the url which is same as earlier, with GET method and no body -

  http://localhost/Service.svc/get/hello


The action looks like below
enter image description here



But when I execute the workflow, the service is not called. Instead the workflow fails to start with a message like -
enter image description here

What could be a possible solution?

  • what did you write into the request/response parameter? – Gwny Sep 17 '14 at 13:52
  • The request and response parameters are empty – Bishnu D. Sep 17 '14 at 15:11
  • more, I also tried to call the service using jQuery AJAX. There is some problem too. As I see on the console the console says 'No 'Access-Control-Allow-Origin' header is present on the requested resource'. Still not sure if the SharePoint workflow is facing the same issue. – Bishnu D. Sep 17 '14 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.