1

I have a few CQWP's in SP2010 Enterprise that I ma using to display tasks from task lists in the same site collection. At the moment they are simply filtered on 'Assigned to [me]' and they are working fine. Only issue is that the query will display all completed tasks too and I want all but completed! I have tried adding another filter that looks at the status field for if the task item is completed. The query looks like this: Assigned to Equals [Me] AND Status is not equal to [Completed]. Problem is the CQWP now displays nothing unless I remove that second filter! What am I doing wrong?? Thanks

Update////

This below CAML works fine...

enter image description here

However I cannot replace 'my name' with the [Me] value so its works for all users! Also I have created a new CQWP and used only one filter of Status is not equal to Completed and this still does not work even though there are tasks set to In Progress and Not started!

7
  • do you want all tasks assigned to you which are not completed? Sep 17, 2014 at 9:00
  • the above query should work its correct. Sep 17, 2014 at 9:04
  • Well its not unfortunately!
    – JazzyN
    Sep 17, 2014 at 9:40
  • I have just tested this with another field. I set the second filter to AND Priority is not equal to Low and this too does not work either. It seems when ever I program a second filter after the assigned to me filter it does not work
    – JazzyN
    Sep 17, 2014 at 9:45
  • which SP Version are you using? Sep 17, 2014 at 9:54

1 Answer 1

1

Status is not equal to [Completed]

Are you using those Square brackets in your view? If so then remove them.

1
  • Thanks James but I've tried it with and without the square brackets.
    – JazzyN
    Sep 17, 2014 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.