8

When I save the information for a project I get the success message, but in the "Manage queued jobs" page I get this error log to checkin workflow:

Geral

Queue:

GeneralQueueJobFailed (26000) - WorkflowCheckinNotify.ProjectCheckinNotifyWorkflowMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='6f1bbee1-983d-e411-944d-00155d0aef58' JobUID='6c1bbee1-983d-e411-944d-00155d0aef58' ComputerName='9f0b20d7-a10a-4a1d-96d3-7d8cba961b4e' GroupType='WorkflowCheckinNotify' MessageType='ProjectCheckinNotifyWorkflowMessage' MessageId='1' Stage='' CorrelationUID='1908b99c-753b-408a-61b4-e1b648595eaf'. For details, check the ULS logs on the computer 9f0b20d7-a10a-4a1d-96d3-7d8cba961b4e to see the entries with JobUID 6c1bbee1-983d-e411-944d-00155d0aef58.

Update LOGS

09/16/2014 08:59:24.19 Microsoft.Office.Project.Server (0x0B84) 0x641C Project Server Queue
ad3fy Critical Standard Information:PSI Entry Point: Project User: Correlation Id: PWA Site URL: SA Name: PSError: A queue job has failed. This is a general error logged by the Project Server Queue everytime a job fails - for effective troubleshooting use this error message with other more specific error messages (if any), the Operations guide (which documents more details about queued jobs) and the trace log (which could provide more detailed context). More information about the failed job follows. GUID of the failed job: 6c1bbee1-983d-e411-944d-00155d0aef58. Name of the computer that processed this job: 9f0b20d7-a10a-4a1d-96d3-7d8cba961b4e (to debug further, you need to look at the trace log from this computer). Failed job type: WorkflowCheckinNot... 1908b99c-753b-408a-61b4-e1b648595eaf 09/16/2014 08:59:24.19 Microsoft.Office.Project.Server (0x0B84) 0x641C Project Server Queue Jobs
ad3fy Medium Error is: GeneralQueueJobFailed. Details: Queue Attributes: 6c1bbee1-983d-e411-944d-00155d0aef58 9f0b20d7-a10a-4a1d-96d3-7d8cba961b4e WorkflowCheckinNotify ProjectCheckinNotifyWorkflowMessage 1
1908b99c-753b-408a-61b4-e1b648595eaf . Standard Information: , LogLevelManager Warning-ulsID:0x000DD158 has no entities explicitly specified. 1908b99c-753b-408a-61b4-e1b648595eaf 09/16/2014 09:00:07.11 OWSTIMER.EXE (0x5F44) 0x6774 SharePoint Foundation Database tzkv High SqlCommand: 'proc_GetTimerJobHistory' CommandType: StoredProcedure CommandTimeout: 300 Parameter: '@RETURN_VALUE' Type: Int Size: 0 Direction: ReturnValue Value: '' Parameter: '@ServiceId' Type: UniqueIdentifier Size: 0 Direction: Input Value: '' Parameter: '@WebApplicationId' Type: UniqueIdentifier Size: 0 Direction: Input Value: '' Parameter: '@ServerId' Type: UniqueIdentifier Size: 0 Direction: Input Value: '9f0b20d7-a10a-4a1d-96d3-7d8cba961b4e'
Parameter: '@JobId' Type: UniqueIdentifier Size: 0 Direction: Input Value: '' Parameter: '@MaximumId' Type: BigInt Size: 0 Direction: Input Value: '-1' Parameter: '@MinimumId' Type: BigInt Size: 0 Direction: Input Value: '-1' Parameter: '@MaximumRows' Type: Int Size: 0 Direction: Input Value: '1'
Parameter... 2408b99c-c53d-408a-61b4-e36f9182bdef

  • 1
    Please, provide information from SharePoint ULS logs. Right now information is not enough to solve your problem. – Ruslan Dayanov Sep 16 '14 at 13:51
  • Done! This is all I found. – Diego Hillesheim Sep 16 '14 at 13:57
0

My favorite is this one: you must create a SharePoint Designer WF for Project Server 2013 and publish it against each PWA instance. See this

if that does not resolve, then this one is worth checking: Are the workflow services functioning / enabled?

PowerShell commands are run from any WF server:

Get-WFFarmStatus
Get-SBFarmStatus

Both commands should return “Running” for the services (2 for WF, 3 for SB). as suggested by the link, restarting the services may resolve.

Hope this Helps,

0

Unfortunately, it's a general error that does not has a direct solution! Meanwhile, there are common reasons that raise this issue like

  • The associated workflow to Enterprise Project Type (EPT) has errors or need to republish.
  • The Workflow Manager is installed but it’s not working properly.
  • The Workflow Manager is installed but it’s not registered properly.
  • You farm need to be updated with January 2016 CU.
  • You have customized the default project site template.

So to trace the issue in details Check GeneralQueueJobFailed (26000).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.