1

I cant get to stop SharePoint foundation web app service. Its stuck on status stopping I have tried the following:

  1. reset IIS

  2. restarted the Timer Service

When I try to use powershell command to stop I get the following error:

Can anyone who went through this help PLEASE

Stop-SPServiceInstance : An object of the type Microsoft.SharePoint.Administration.SPServiceInstanceJobDefinition named "job-service-instance-1ff39eb2-12d2-457d-a749-265e350eb1b1" already exists under the parent Microsoft.SharePoint.Administration.SPTimerService named "SPTimerV4". Rename your object or delete the existing object. At line:1 char:127 + ... pplication"} | Stop-SPServiceInstance + ~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidData: (Microsoft.Share...ServiceInstance: SPCmdletStopServiceInstance) [Stop-SPServiceInstance], SPDuplicateObjectEx ception + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletStopServ iceInstance

1

I think I've had simmilar problem. Make sure both SharePoint Timer and Administration services are running.

To get the status with PowerShell:

Get-Service sptimerv4, spadminv4

Restart services:

Get-Service sptimerv4, spadminv4 | ? Status -NE Running | Restart-Service
|improve this answer|||||
0

Provision the service and re-start IIS. This was resolved in one of the CU updates. By the way on which SharePoint-CU version you are ?

|improve this answer|||||
  • Manu when you say provision what do you mean? Any commands to be used? – naijacoder Sep 16 '14 at 7:55
  • Anyone went through this before? – naijacoder Sep 16 '14 at 11:00
  • Refer this URL:adrit.de/Blog/Post/9/… . This I have used for search service, something like this. – Manu Singh Sep 17 '14 at 6:09
0

I had the same issue. It seems that the job was not able to be stopped in the original server. It can run on a different app server. These are the steps that I follow to successfully delete that job

#trying to get a list of the SP timer jobs
Get-SPTimerJob | Where-Object {$_.Name -Like "job-service-instance-*"} | Sort-Object Name | Select-Object name, ID, Status

Then you get the jobID, and that status that says that it is "online" when I try to disable it through PS:

#this PS "should" disable that timer job, but it doesn't work
Disable-SPTimerJob -Identity "<GUID>"

it did nothing. It keep saying that the job was still online. I even went and restart SP timer job, but it did nothing. I've found this article from TechNet: https://blogs.technet.microsoft.com/okoestner/2010/04/28/how-to-delete-a-timer-job-definition

this is the code that I ran:

#this code WORKS.!
stsadm.exe -o deleteconfigurationobject -id <GUID>

now, I can run the ups autofixer from SharePoint Bjorn and get my ups running.

hope this helps someone

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.