0

SP2013 Enterprise, separate SQL 2012 server, single server farm, ~150 users

The local SP farm has been extremely overtaxed lately (24/7) and I can't figure out why. Here's a shot of what the resource usage looks like:

Task Manager

The Timer Service in particular seems to eat up most of the resources, at times up to 75% of the CPU and 80% of the memory just by iteself. This is a pretty small deployment with nothing crazy going on, and at the time this shot was taken there are no active crawls or other events that should be taking up this kind of juice. This server has 4 virtual cores at 2.4GHz and 20 GB of memory, so I don't get why it's choking so hard on simply idling. Can anyone spot the problem here? I don't know enough about what processes should be taking up to determine if anything in that list is disproportional. Until the past month this server was humming along just fine, and as far as I know the amount of resources allotted to the server should be way more than enough to run it.

Edit: As requested, here is a peek into the ULS log showing what the OWSTIMER.EXE process is doing. These events are occurring a couple times a second, sometimes more:

UpdatedConcurrencyException: The object UserProfileImportJob Name=User Profile Service Application_ProfileImportJob was updated by another user. Determine if these changes will conflict, resolve any differences, and reapply the second change. This error may also indicate a programming error caused by obtaining two copies of the same object in a single thread. Previous update information: User: [domain\farm_admin_account] Process:OWSTIMER (2004) Machine:[server] Time:September 11, 2014 09:20:44.0000 Current update information: User: [domain\farm_admin_account] Process:OWSTIMER (2012) Machine:[server] Time:September 15, 2014 12:46:39.1883 ConcurrencyException: Old Version : 5202587 New Version : 5202587

  • did you check the ULS logs and see what timer services trying to do? also have a look on this pauldevenney.blogspot.com/2007/12/… – Waqas Sarwar MVP Sep 15 '14 at 12:55
  • I edited the question with some samples from ULS logs. Unfortunately that link didn't help me solve the issue. – thanby Sep 15 '14 at 16:58
4

I just hade the same problem and I resolved it by clearing the SharePoint cache. I just followed the steps below which are described in detail here: http://www.jeremytaylor.net/2013/10/12/clear-sharepoint-cache/

  1. Stop the SharePoint Timer service (on all servers in the farm)
  2. Backup the Cache.ini-file (on all servers in the farm) Go to %SystemDrive%\ProgramData\Microsoft\SharePoint\Config\ in Explorer. I had four guid-folders. Two of them contained Cache.ini, xml- and xmltmp-files. Check which of the folders that has the latest modified Cache-ini. Copy the ini-file to a backup folder.
  3. Delete the XML-files (and xmltemp-files if they exist) from the folder above (on all servers in the farm). Open the Cache.ini-file and replace the current number with 1. Save the file (on all servers in the farm).
  4. Start the SharePoint Timer service (on all servers in the farm)

After that I went to Central administration. The time for loading the page was longer than normal (just the first time) but during the same time the xml-files were generated again and the Cache.ini was changed to the the value from the back up + 4.

The log-files from the Diagnostic logging (every 30 min) were reduced from over 150 mb to 5-15 mb and the error above was no longer appearing in the log-files.

  • Just had the same problem, with same error message (UpdatedConcurrencyException) in the logs. Clearing the cache fixed this! Patrik, thanks a lot for sharing the solution, you saved my day! :) – Andrey Markeev Jan 28 '15 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.