In Central Administration I went to System Settings->Manage Farm Solutions

In there I selected the WSP I want to retract, clicked the Retract Solution link and clicked "OK" with all of the default values selected.

It then goes back to the "Solution Management" page and the status says "Retracting(Scheduled at ...)" with the current time in place of ...

For some reason when I go back to this page after a few minutes and check the Status it is back to deployed. What am I doing wrong?

  • Are any errors reported when you go back into the page which lets you retract the solution?
    – James Love
    Apr 19, 2011 at 16:41
  • I notice this from time to time that it will be fully retracted from my content web applications but is still deployed to the Central Admin web application. Retracting it again usually resolves that and then can be removed. Apr 19, 2011 at 16:46
  • Are you certain you aren't looking at a browser cached version of the solutions page? hit Shift-F5 to reload it from the server
    – Dave Wise
    Apr 19, 2011 at 16:46
  • @James, no errors. @Pirate, I have tried several times with no luck. @Dave, no luck with the hard refresh. Apr 19, 2011 at 16:59
  • you should check your ULS and Event Log for errors too. To check for errors in deployment use PowerShell Get-SPSolution | select DisplayName, LastOperationResult Apr 19, 2011 at 17:30

6 Answers 6


Not sure why it wasn't working through the Central Admin but I ended up doing it through the Management Console using the following commands:

Uninstall-SPSolution -Identity mySolution.wsp -allwebapplications
Remove-SPSolution -identity mySolution.wsp -force

Hope this helps someone.


deactivate the features that is deployed by the wsp. Some times this happens due to the features that may be in use while it is trying to retract the solution

  • 2
    where can I deactivate it? Dec 12, 2012 at 18:53

I had the same issue and managed to retract the solution using the PowerShell command:

Uninstall-SPSolution -Identity {id} -AllWebApplications -CompatibilityLevel All -Local

Without the "-Local" the retraction job would never complete.

I noticed that afterwards, the solution is then still deployed to the central admin web application (i.e. "Deployed to http://servername:12216/) despite the "-AllWebApplications" switch.

However, calling

Remove-SPSolution "{name}" -Force

removed the solution.

To find the Names and Ids of the solution, I used:


From Central Administration http://yoursever:port/_admin/Solutions.aspx choose your solution, first retract and then delete it.


Here another solution that I have tried successfully:

In SharePoint 2010 Management Shell run net stop "SharePoint 2010 Timer" and thereafter run net start "SharePoint 2010 Timer"

Go back to retract the solution


If you use the -force action, be ready for the problems.

The Solution can get stuck into memory and will not come out. This causes issues later when trying to deploy or use the server with Visual Studio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.