0

A Sharepoint Site Collection was restored on a fresh installation of sharepoint foundation on a server. Upon restoring the 22GB back up file, I am not able to see the restored site
collection sites/abc I get a 404 - Webpage can not be found I checked the content database an there is a good 21 GB in there. There is nothing else but this site collection in this instance of sharepoint. What could be the problem? The usage logs for the time when the restoration was running was 0KB. The STSADM restoration command executed over a couple of hours with no hitches. Event log viewer had "Distributed Cache service is not enabled in this server", so I went and enabled it. What am I missing? Desperately need help.

Regards, Nita

5
  • Is the site collection present in central admin? Sep 12, 2014 at 9:05
  • Yep @user19952 it is.
    – Nita
    Sep 12, 2014 at 9:21
  • And you restored the sitecollection from a .bak file? Did you restore it to a webapplication with a existing rootsite? Sep 12, 2014 at 9:23
  • 1
    @user19952 problem solved!! Attached and reattached content db! But why was the attachment incomplete/imperfect in the first place? Beats me. What do you think?
    – Nita
    Sep 12, 2014 at 9:28
  • I'm glad you solved the problem! :) I cant really answer why it did work.. but attaching/detaching a database has helped me solve things before.. Magic of SharePoint. Sep 12, 2014 at 9:31

1 Answer 1

1

My dear comrades, this problem has been nagging me since 2 weeks. I have tried anything and every possible solution suggested on the internet, even if some were remotely connected. I had sat on my peers' heads to give me some clues to fix this issue... and guess what fixed it how

... ACT OF DESPERATION:

I detached the content DB and then attached it. Thats it! Now the site comes up. Now it leads to the question, why did this happen in the first place? Has anyone experienced this before?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.