7

I am using SharePoint 2010 at the moment.

For some stupid reason when I create a sub-site and I am inside that sub-site the breadcrumb does not show the parent site.

It stops at the current site level.....errrr

Can this be modified/changed?

In SharePoint 2007 this was no issue!

Thanks in advanced!

2
  • what site type? is the parent a SPSite and the child SPWeb or SPSite? have you enabled the portal connection in site settings?
    – djeeg
    Apr 19, 2011 at 12:34
  • Both plain SharePoint Sites, what portal connection you talking about?
    – Etienne
    Apr 19, 2011 at 13:17

3 Answers 3

10

Found the answer... I replaced:

<SharePoint:SPLinkButton runat="server" NavigateUrl="~site/" id="onetidProjectPropertyTitle"><SharePoint:ProjectProperty Property="Title" runat="server" /></SharePoint:SPLinkButton>

With:

<asp:SiteMapPath
     runat="server"
     SiteMapProviders="SPSiteMapProvider,SPXmlContentMapProvider"
     RenderCurrentNodeAsLink="false"
     NodeStyle-CssClass="breadcrumbNode"
     CurrentNodeStyle-CssClass="breadcrumbCurrentNode"
     RootNodeStyle-CssClass="breadcrumbRootNode"
     HideInteriorRootNodes="true"
     SkipLinkText=""/>

In my MasterPage. I got this from the NightandDay.Master Masterpage.

5
  • The code Etienne posted IS the answer. Works great! Thank you.
    – Terri
    Mar 21, 2012 at 20:19
  • That did successfully add the parent site as the root node. However it also made a double-entry of page titles (from publishing page libraries). Any thoughts on how to modify it?
    – user9134
    Jun 27, 2012 at 13:16
  • I am a beginner in SharePoint. I am using SharePoint 2010 Standard. I tried your suggestion but my subsite still does not show the Parent site. I should be replacing the codes in v4.master...right? Should I be modifying the subsite v4.master file instead of the parent v4.master file?Did I miss a step some where? Thank you in advance for your help. Steve
    – user11359
    Oct 15, 2012 at 20:52
  • This didn't work for me. I still see the same thing pretty much (same problem as user11359's comment above). Any ideas?
    – Mike Cheel
    Jan 10, 2014 at 15:48
  • I am a bit late with anwsering, but it is the selected master page of the subsite you need to edit. Also if you generate your subsites edit the master page in the template you generate the subsite from. One might think this would be a Feature anyone would want as a default. Also if you can't find the correct position add it below the <h1> with Id pageTitle. Jun 27, 2016 at 9:25
0

When creating the site you can click the more options button and make you selection about nacgation

Hope this helps

3
  • It's not the navigation that's the problem, the problem is the breadcrumb does not show the parent site.
    – Etienne
    Apr 19, 2011 at 13:10
  • you know that the breadcrumb is now that little folder with the arrow right ? (next to site actions)
    – Renzo
    Apr 19, 2011 at 14:05
  • yes I know of that, but the V4.master Masterpage also have one next to the banner.....have a look....that's the one I am talking about.
    – Etienne
    Apr 21, 2011 at 6:19
0

Go to Site Settings and then Look and Feel --> Top link bar. You can then set it to "Use Links from Parent". This will add the parent site to the link bar after the fact. You can also set it when creating the site as Renzo says.

3
  • There is no Top link bar under my Look and Feel section.....
    – Etienne
    Apr 19, 2011 at 12:50
  • 2
    If Top Link bar isn't listed, then it sounds as if the publishing features are enabled, so you'd want to look for the Navigation link in the Look and Feel section. Apr 19, 2011 at 12:55
  • That is correct, it does have Navigation, and it does use the navigation from the parent site, but it does not show the parent site in the actual breadcrumb.
    – Etienne
    Apr 19, 2011 at 13:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.