I have two SharePoint Enterprise 2010 sites in two different farms. Both sites I am accessing with my local browser IE 10 (32-bit). List1 in Site1 can be opened in DataSheet view but List2 in Site2 cannot be opened in DataSheet view. I have 64-bit Office 2013 installed. I am using 64-bit Office but still can open List1 of Site1 in DataSheet view but cannot open List2 in Site2 in DataSheet view which is in another farm. This is quite strange! Any advice and suggestions what is wrong or missing?

Here is the common exception I encounter while opening List2 of Site2 in DataSheet view:

The list cannot be displayed in DataSheet view for one or more of the following reasons:

  • A datasheet component compatible with Microsoft SharePoint Foundation is not installed.

  • Your web browser does not support ActiveX controls.

  • A component is not properly configured for 32-bit or 64-bit support.

  • Have you set up excel services in both farms? Check that excel calculation service is started and that the excel service application is created. – Christoffer Sep 11 '14 at 7:31
  • This thread might help you to: social.technet.microsoft.com/Forums/sharepoint/en-US/… – Christoffer Sep 11 '14 at 7:32
  • Check that both sites are connecting using the same security level in IE. To do this open the working list, go to Internet options in IE and select the Security tab. I suspect this site will be Local Intranet or Trusted sites. Do the same for the site that doesn't work, I suspect you'll find its Internet. If it is try adding the site to the same security level as the one that works (Though you may find the option to do so is locked down as some companies have policies to prevent users changing these settings). – PistonBlown Sep 11 '14 at 12:15
  • PS Datasheet has nothing to do with Excel Services. Its controlled by a DLL that's supplied with Microsoft Office. If your running 64-bit Office then normally the datasheet view doesn't work but if you also have some office 32 bit stuff installed (or commonly people install the Access 2007 Runtime) then it will. In your case you must have the right DLL installed as otherwise it wouldn't work at all. – PistonBlown Sep 11 '14 at 12:18

Instaling of "2007 Office System Driver: Data Connectivity Components" resolved issue for me. Here is the link - http://www.microsoft.com/en-us/download/details.aspx?id=23734

I just had this issue myself and was able to resolve it by performing the following steps:

  • Close any and all open Excel windows.
  • Open a new browser process (For IE, press AltF, then I).
  • Navigate to the same list and attempt to access datasheet view again.

Apparently, in my case, the issue was related to something in memory from one of my running Excel processes.

  • Closing excel windows worked for me. Thanks. – P S Dec 5 '16 at 12:17

I get this same issue from time to time, restarting my computer resolves it for me for months at a time. Not permanent solution, but worth a try while your looking for the solution.

This solved it for me: Data Connectivity Components https://www.microsoft.com/en-us/download/confirmation.aspx?id=23734

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.