0

I have created a custom master page with code behind an deployed it as a module in the _catalogs/masterpage folder. The master page should be used by a custom customer pages, but all I get is the following error:

Could not load type xxx from the assembly xxx

saying that the system could not load type the codebehind class type from the assembly. Does sharepoint have any exclusion/filter in the types it can load?

Here is my module file:

//module
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
    <Module Name="MasterPageModule" Url="_catalogs/masterpage" List="116">
         <File Path="Pages\seattle.Master" Url="Pages/seattle.Master" />
    </Module>
</Elements>

enter image description here

  • Hi Ezzaam. I have edited your message to make it more readable. As a reference, when posting error message, try to use the block quote formatting, not the code one. – SPArchaeologist Sep 5 '14 at 10:55
  • Did you deploy your assembly to GAC? Check GAC if you assembly is deployed properly. – Aanchal Sep 5 '14 at 12:27
  • yeah it's there – ezzaam Sep 5 '14 at 13:30
0

Have you checked the master page gallery to make sure it is checked in and published?

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    yead definitely i did the problem could load the type from assembly – ezzaam Sep 5 '14 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.