1

We are trying to configure email alerts on the Central Admin Health Report list in SharePoint 2013. We get the confirmation email when the alert is first created, but nothing when a new error or warning arrives in the list.

Sure enough, no 'job-immediate-alert' existed on the CA webapp, as determined by viewing the CA UI Job definition page and the following powershell: Get-SPTimerJob | ? {$_.name -like "*alert*"}

To create the job on the CA webapp I followed the advice here. Now I can see in the Job Definition page the ‘Immediate Alerts’ job. However, when I click to see details about the job the Last run time is N/A.

I see the Immediate Alerts job scheduled in the Scheduled Jobs page, but the Job History page is empty. I have tried to start the job manually with Powershell with the following:

Add-PSSnapin "Microsoft.SharePoint.PowerShell" -ErrorAction SilentlyContinue
$th = Get-SPTimerJob -WebApplication http://spsite:2013 | ? {$_.name -like "*alert*"} 
Start-SPTimerJob $th

No errors, but still the Last run time is N/A

Some users have said running the updatealerttemplates may help, so ran stsadm -o updatealerttemplates -url http://spsite:2013 but the job still will not run. I restarted the Timer Service via Windows Services as well, but still no luck.

No errors in Event Viewer or ULS. The job just seems to refuse to run on the CA Webapp. Anyone have any suggestions? (Would rather not have to create a workflow just for this – this should be simple, right?)

UPDATE: The servers restarted today, and the job-immediate-alerts timer job ran successfully TWICE on the SharePoint Central Administration v4 WebApp. After running twice, something seems to prevent it from processing the job. Very strange.

  • Sounds like this: social.technet.microsoft.com/Forums/en-US/… . Wonder why CA lists would have 'Alert Me' interface if it is unable to send an alert... is this just me? – Robbie Sep 4 '14 at 0:36
  • run this one and see if the job enable for CA stsadm -o getproperty -pn job-immediate-alerts -url server:port – Waqas Sarwar MVP Sep 4 '14 at 16:43
  • Yes, Property exists=yes and is set to run every five minutes. – Robbie Sep 4 '14 at 21:09
  • Waqas, Did you guys ever come up with a root cause? I'm having the exact same issue. Thanks! Hi Waqas! Joe – Joe Apr 3 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.